packages/net/xl2tpd/patches/110-makefile_dont_build_pfc.patch
thepeople 9cb6f12ea8 this patch updates xl2tpd to 1.2.5. From the changelog:
* Fix initscript for
https://bugzilla.redhat.com/show_bug.cgi%3Fid%3D247100
* Fix for two Windows machines behind the same NAT with the same
 number of l2tp connection attempts since boot [Shinichi Furuso]

Changes in this patch:

* use PKG_INSTALL:=1
* use standard config file names like in other major distributions
* new patch to disable building pfc (which was not installed anyway),
 removes dependency to libpcap
* include a commented sample config file
* use INSTALL_CONF instead of INSTALL_DATA + chmod 0600

-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20276 3c298f89-4303-0410-b956-a3cf2f4a3e73
2010-03-18 16:01:35 +00:00

41 lines
959 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -104,22 +104,18 @@ BINDIR?=$(DESTDIR)${PREFIX}/bin
MANDIR?=$(DESTDIR)${PREFIX}/share/man
-all: $(EXEC) pfc
+all: $(EXEC)
clean:
- rm -f $(OBJS) $(EXEC) pfc.o pfc
+ rm -f $(OBJS) $(EXEC)
$(EXEC): $(OBJS) $(HDRS)
$(CC) $(LDFLAGS) -o $@ $(OBJS) $(LDLIBS)
-pfc:
- $(CC) $(CFLAGS) -c contrib/pfc.c
- $(CC) $(LDFLAGS) -lpcap $(LDLIBS) -o pfc pfc.o
-
romfs:
$(ROMFSINST) /bin/$(EXEC)
-install: ${EXEC} pfc
+install: ${EXEC}
install -d -m 0755 ${SBINDIR}
install -m 0755 $(EXEC) ${SBINDIR}/$(EXEC)
install -d -m 0755 ${MANDIR}/man5
@@ -127,11 +123,6 @@ install: ${EXEC} pfc
install -m 0644 doc/xl2tpd.8 ${MANDIR}/man8/
install -m 0644 doc/xl2tpd.conf.5 doc/l2tp-secrets.5 \
${MANDIR}/man5/
- # pfc
- install -d -m 0755 ${BINDIR}
- install -m 0755 pfc ${BINDIR}/pfc
- install -d -m 0755 ${MANDIR}/man1
- install -m 0644 contrib/pfc.1 ${MANDIR}/man1/
# openbsd
# install -d -m 0755 /var/run/xl2tpd