a1198b8865
git-svn-id: svn://svn.openwrt.org/openwrt/packages@35237 3c298f89-4303-0410-b956-a3cf2f4a3e73
41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -1,3 +1,7 @@
|
|
+BASE=.
|
|
+
|
|
+include $(BASE)/build/openwrt_rules.mk
|
|
+
|
|
EXTRA_DIST =
|
|
SUBDIRS = . src
|
|
AUTOMAKE_OPTIONS = foreign
|
|
@@ -69,7 +73,7 @@ cd-moh-install: uhd-moh-install sounds-m
|
|
# (1) if the variable is set in `config.status', edit `config.status'
|
|
# (which will cause the Makefiles to be regenerated when you run `make');
|
|
# (2) otherwise, pass the desired values on the `make' command line.
|
|
-all-recursive: libfreeswitch.la
|
|
+all-recursive: spandsp-reconf libfreeswitch.la
|
|
clean-recusive: clean_core
|
|
install-recursive: install-libLTLIBRARIES install-binPROGRAMS
|
|
|
|
@@ -621,7 +625,9 @@ sndfile-reconf:
|
|
|
|
tiff-reconf:
|
|
cd libs/tiff-4.0.2 && autoreconf -fi
|
|
- cd libs/tiff-4.0.2 && sh ./configure.gnu
|
|
+ cd libs/tiff-4.0.2 && sh ./configure.gnu --host="$(GNU_TARGET_NAME)" --prefix="/usr"
|
|
+ cd libs/spandsp && autoreconf -fi
|
|
+ cd libs/spandsp && sh ./configure.gnu --host="$(GNU_TARGET_NAME)" --prefix="/usr"
|
|
cd libs/tiff-4.0.2 && make
|
|
|
|
python-reconf:
|
|
@@ -646,9 +652,6 @@ iks-reconf:
|
|
$(MAKE) mod_dingaling-clean
|
|
|
|
spandsp-reconf: tiff-reconf
|
|
- cd libs/spandsp && $(MAKE) clean || echo
|
|
- cd libs/spandsp && autoreconf -fi
|
|
- cd libs/spandsp && sh ./configure.gnu --prefix=$(prefix)
|
|
cd libs/spandsp && $(MAKE)
|
|
|
|
sofia-reconf:
|