packages/net/hping3/patches/100-makefile.patch
florian a410615192 [package] add hping3 (#4699)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15166 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-04-09 13:25:03 +00:00

49 lines
1.4 KiB
Diff

--- hping3-20051105_orig/Makefile 2005-11-05 11:31:41.000000000 +0100
+++ hping3-20051105/Makefile 2009-02-26 13:44:40.000000000 +0100
@@ -6,15 +6,15 @@
# $date: Sun Jul 25 17:56:15 MET DST 1999$
# $rev: 3$
-CC= gcc
-AR=/usr/bin/ar
-RANLIB=/usr/bin/ranlib
-CCOPT= -O2 -Wall -I/usr/include/tcl8.4 -DUSE_TCL
-DEBUG= -g
+#CC= gcc
+#AR=/usr/bin/ar
+#RANLIB=/usr/bin/ranlib
+#CCOPT= -O2 -Wall
+#DEBUG= -g
#uncomment the following if you need libpcap based build under linux
#(not raccomanded)
COMPILE_TIME=
-INSTALL_MANPATH=/usr/local/man
+#INSTALL_MANPATH=/usr/local/man
PCAP=-lpcap
ARSOBJ = ars.o apd.o split.o rapd.o
@@ -50,20 +50,16 @@
$(RANLIB) $@
hping3: byteorder.h $(OBJ)
- $(CC) -o hping3 $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) -ltcl8.4 -lm -lpthread
- @echo
- ./hping3 -v
- @echo "use \`make strip' to strip hping3 binary"
- @echo "use \`make install' to install hping3"
+ $(CC) -o hping3 $(CFLAGS) $(LDFLAGS) $(DEBUG) $(OBJ) $(PCAP) -lm -lpthread
hping3-static: byteorder.h $(OBJ)
- $(CC) -static -o hping3-static $(CCOPT) $(DEBUG) $(OBJ) -L/usr/local/lib $(PCAP) -ltcl8.4 -lm -lpthread -ldl
+ $(CC) -static -o hping3-static $(CFLAGS) $(LDFLAGS) $(DEBUG) $(OBJ) $(PCAP) -lm -lpthread -ldl
byteorder.h:
./configure
.c.o:
- $(CC) -c $(CCOPT) $(DEBUG) $(COMPILE_TIME) $<
+ $(CC) -c $(CFLAGS) $(LDFLAGS) $(DEBUG) $(COMPILE_TIME) $<
clean:
rm -rf hping3 *.o libars.a