c14f4648e2
Python can either use it's own implementation for the hashlib functions or it can use openssl. If openssl is installed it will choose the openssl based variant. But since openssl is not a dependency, but could have been build before python we'll have to force the python build to choose the internal variant. Fixes #6883 git-svn-id: svn://svn.openwrt.org/openwrt/packages@20372 3c298f89-4303-0410-b956-a3cf2f4a3e73
29 lines
1.1 KiB
Diff
29 lines
1.1 KiB
Diff
diff --git a/setup.py b/setup.py
|
|
index 0e08e74..65161db 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -622,9 +622,10 @@ class PyBuildExt(build_ext):
|
|
|
|
#print 'openssl_ver = 0x%08x' % openssl_ver
|
|
|
|
- if (ssl_incs is not None and
|
|
- ssl_libs is not None and
|
|
- openssl_ver >= 0x00907000):
|
|
+# if (ssl_incs is not None and
|
|
+# ssl_libs is not None and
|
|
+# openssl_ver >= 0x00907000):
|
|
+ if False:
|
|
# The _hashlib module wraps optimized implementations
|
|
# of hash functions from the OpenSSL library.
|
|
exts.append( Extension('_hashlib', ['_hashopenssl.c'],
|
|
@@ -644,7 +645,8 @@ class PyBuildExt(build_ext):
|
|
depends = ['md5.h']) )
|
|
missing.append('_hashlib')
|
|
|
|
- if (openssl_ver < 0x00908000):
|
|
+# if (openssl_ver < 0x00908000):
|
|
+ if True:
|
|
# OpenSSL doesn't do these until 0.9.8 so we'll bring our own hash
|
|
exts.append( Extension('_sha256', ['sha256module.c']) )
|
|
exts.append( Extension('_sha512', ['sha512module.c']) )
|