aa16c62e56
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24584 3c298f89-4303-0410-b956-a3cf2f4a3e73
276 lines
8.8 KiB
Diff
276 lines
8.8 KiB
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -12070,7 +12070,7 @@ fi
|
|
## Check for optional header files
|
|
|
|
|
|
-for ac_header in ifaddrs.h ieee1284.h
|
|
+for ac_header in ifaddrs.h
|
|
do
|
|
as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
|
if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
@@ -13690,235 +13690,6 @@ case $host in
|
|
cat >>confdefs.h <<_ACEOF
|
|
#define HOST_OS LINUX
|
|
_ACEOF
|
|
-
|
|
-
|
|
-for ac_header in ieee1284.h
|
|
-do
|
|
-as_ac_Header=`$as_echo "ac_cv_header_$ac_header" | $as_tr_sh`
|
|
-if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
- { $as_echo "$as_me:$LINENO: checking for $ac_header" >&5
|
|
-$as_echo_n "checking for $ac_header... " >&6; }
|
|
-if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
- $as_echo_n "(cached) " >&6
|
|
-fi
|
|
-ac_res=`eval 'as_val=${'$as_ac_Header'}
|
|
- $as_echo "$as_val"'`
|
|
- { $as_echo "$as_me:$LINENO: result: $ac_res" >&5
|
|
-$as_echo "$ac_res" >&6; }
|
|
-else
|
|
- # Is the header compilable?
|
|
-{ $as_echo "$as_me:$LINENO: checking $ac_header usability" >&5
|
|
-$as_echo_n "checking $ac_header usability... " >&6; }
|
|
-cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-$ac_includes_default
|
|
-#include <$ac_header>
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext
|
|
-if { (ac_try="$ac_compile"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
|
-$as_echo "$ac_try_echo") >&5
|
|
- (eval "$ac_compile") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest.$ac_objext; then
|
|
- ac_header_compiler=yes
|
|
-else
|
|
- $as_echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- ac_header_compiler=no
|
|
-fi
|
|
-
|
|
-rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
|
-{ $as_echo "$as_me:$LINENO: result: $ac_header_compiler" >&5
|
|
-$as_echo "$ac_header_compiler" >&6; }
|
|
-
|
|
-# Is the header present?
|
|
-{ $as_echo "$as_me:$LINENO: checking $ac_header presence" >&5
|
|
-$as_echo_n "checking $ac_header presence... " >&6; }
|
|
-cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-#include <$ac_header>
|
|
-_ACEOF
|
|
-if { (ac_try="$ac_cpp conftest.$ac_ext"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
|
-$as_echo "$ac_try_echo") >&5
|
|
- (eval "$ac_cpp conftest.$ac_ext") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } >/dev/null && {
|
|
- test -z "$ac_c_preproc_warn_flag$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- }; then
|
|
- ac_header_preproc=yes
|
|
-else
|
|
- $as_echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- ac_header_preproc=no
|
|
-fi
|
|
-
|
|
-rm -f conftest.err conftest.$ac_ext
|
|
-{ $as_echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
|
|
-$as_echo "$ac_header_preproc" >&6; }
|
|
-
|
|
-# So? What about this header?
|
|
-case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
|
|
- yes:no: )
|
|
- { $as_echo "$as_me:$LINENO: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&5
|
|
-$as_echo "$as_me: WARNING: $ac_header: accepted by the compiler, rejected by the preprocessor!" >&2;}
|
|
- { $as_echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the compiler's result" >&5
|
|
-$as_echo "$as_me: WARNING: $ac_header: proceeding with the compiler's result" >&2;}
|
|
- ac_header_preproc=yes
|
|
- ;;
|
|
- no:yes:* )
|
|
- { $as_echo "$as_me:$LINENO: WARNING: $ac_header: present but cannot be compiled" >&5
|
|
-$as_echo "$as_me: WARNING: $ac_header: present but cannot be compiled" >&2;}
|
|
- { $as_echo "$as_me:$LINENO: WARNING: $ac_header: check for missing prerequisite headers?" >&5
|
|
-$as_echo "$as_me: WARNING: $ac_header: check for missing prerequisite headers?" >&2;}
|
|
- { $as_echo "$as_me:$LINENO: WARNING: $ac_header: see the Autoconf documentation" >&5
|
|
-$as_echo "$as_me: WARNING: $ac_header: see the Autoconf documentation" >&2;}
|
|
- { $as_echo "$as_me:$LINENO: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&5
|
|
-$as_echo "$as_me: WARNING: $ac_header: section \"Present But Cannot Be Compiled\"" >&2;}
|
|
- { $as_echo "$as_me:$LINENO: WARNING: $ac_header: proceeding with the preprocessor's result" >&5
|
|
-$as_echo "$as_me: WARNING: $ac_header: proceeding with the preprocessor's result" >&2;}
|
|
- { $as_echo "$as_me:$LINENO: WARNING: $ac_header: in the future, the compiler will take precedence" >&5
|
|
-$as_echo "$as_me: WARNING: $ac_header: in the future, the compiler will take precedence" >&2;}
|
|
-
|
|
- ;;
|
|
-esac
|
|
-{ $as_echo "$as_me:$LINENO: checking for $ac_header" >&5
|
|
-$as_echo_n "checking for $ac_header... " >&6; }
|
|
-if { as_var=$as_ac_Header; eval "test \"\${$as_var+set}\" = set"; }; then
|
|
- $as_echo_n "(cached) " >&6
|
|
-else
|
|
- eval "$as_ac_Header=\$ac_header_preproc"
|
|
-fi
|
|
-ac_res=`eval 'as_val=${'$as_ac_Header'}
|
|
- $as_echo "$as_val"'`
|
|
- { $as_echo "$as_me:$LINENO: result: $ac_res" >&5
|
|
-$as_echo "$ac_res" >&6; }
|
|
-
|
|
-fi
|
|
-as_val=`eval 'as_val=${'$as_ac_Header'}
|
|
- $as_echo "$as_val"'`
|
|
- if test "x$as_val" = x""yes; then
|
|
- cat >>confdefs.h <<_ACEOF
|
|
-#define `$as_echo "HAVE_$ac_header" | $as_tr_cpp` 1
|
|
-_ACEOF
|
|
-
|
|
-else
|
|
- { { $as_echo "$as_me:$LINENO: error: ( required header file ieee1284.h missing)" >&5
|
|
-$as_echo "$as_me: error: ( required header file ieee1284.h missing)" >&2;}
|
|
- { (exit 1); exit 1; }; }
|
|
-fi
|
|
-
|
|
-done
|
|
-
|
|
-
|
|
-{ $as_echo "$as_me:$LINENO: checking for ieee1284_open in -lieee1284" >&5
|
|
-$as_echo_n "checking for ieee1284_open in -lieee1284... " >&6; }
|
|
-if test "${ac_cv_lib_ieee1284_ieee1284_open+set}" = set; then
|
|
- $as_echo_n "(cached) " >&6
|
|
-else
|
|
- ac_check_lib_save_LIBS=$LIBS
|
|
-LIBS="-lieee1284 $LIBS"
|
|
-cat >conftest.$ac_ext <<_ACEOF
|
|
-/* confdefs.h. */
|
|
-_ACEOF
|
|
-cat confdefs.h >>conftest.$ac_ext
|
|
-cat >>conftest.$ac_ext <<_ACEOF
|
|
-/* end confdefs.h. */
|
|
-
|
|
-/* Override any GCC internal prototype to avoid an error.
|
|
- Use char because int might match the return type of a GCC
|
|
- builtin and then its argument prototype would still apply. */
|
|
-#ifdef __cplusplus
|
|
-extern "C"
|
|
-#endif
|
|
-char ieee1284_open ();
|
|
-int
|
|
-main ()
|
|
-{
|
|
-return ieee1284_open ();
|
|
- ;
|
|
- return 0;
|
|
-}
|
|
-_ACEOF
|
|
-rm -f conftest.$ac_objext conftest$ac_exeext
|
|
-if { (ac_try="$ac_link"
|
|
-case "(($ac_try" in
|
|
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
|
- *) ac_try_echo=$ac_try;;
|
|
-esac
|
|
-eval ac_try_echo="\"\$as_me:$LINENO: $ac_try_echo\""
|
|
-$as_echo "$ac_try_echo") >&5
|
|
- (eval "$ac_link") 2>conftest.er1
|
|
- ac_status=$?
|
|
- grep -v '^ *+' conftest.er1 >conftest.err
|
|
- rm -f conftest.er1
|
|
- cat conftest.err >&5
|
|
- $as_echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
|
- (exit $ac_status); } && {
|
|
- test -z "$ac_c_werror_flag" ||
|
|
- test ! -s conftest.err
|
|
- } && test -s conftest$ac_exeext && {
|
|
- test "$cross_compiling" = yes ||
|
|
- $as_test_x conftest$ac_exeext
|
|
- }; then
|
|
- ac_cv_lib_ieee1284_ieee1284_open=yes
|
|
-else
|
|
- $as_echo "$as_me: failed program was:" >&5
|
|
-sed 's/^/| /' conftest.$ac_ext >&5
|
|
-
|
|
- ac_cv_lib_ieee1284_ieee1284_open=no
|
|
-fi
|
|
-
|
|
-rm -rf conftest.dSYM
|
|
-rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
|
|
- conftest$ac_exeext conftest.$ac_ext
|
|
-LIBS=$ac_check_lib_save_LIBS
|
|
-fi
|
|
-{ $as_echo "$as_me:$LINENO: result: $ac_cv_lib_ieee1284_ieee1284_open" >&5
|
|
-$as_echo "$ac_cv_lib_ieee1284_ieee1284_open" >&6; }
|
|
-if test "x$ac_cv_lib_ieee1284_ieee1284_open" = x""yes; then
|
|
- cat >>confdefs.h <<_ACEOF
|
|
-#define HAVE_LIBIEEE1284 1
|
|
-_ACEOF
|
|
-
|
|
- LIBS="-lieee1284 $LIBS"
|
|
-
|
|
-else
|
|
- { { $as_echo "$as_me:$LINENO: error: Library not found" >&5
|
|
-$as_echo "$as_me: error: Library not found" >&2;}
|
|
- { (exit 1); exit 1; }; }
|
|
-fi
|
|
;;
|
|
|
|
*-*-solaris2.*)
|
|
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -60,7 +60,7 @@ fi
|
|
|
|
|
|
## Check for optional header files
|
|
-AC_CHECK_HEADERS([ifaddrs.h ieee1284.h])
|
|
+AC_CHECK_HEADERS([ifaddrs.h])
|
|
|
|
## Check for mandatory header files
|
|
|
|
@@ -95,15 +95,7 @@ AC_TYPE_UINT32_T
|
|
AC_TYPE_UINT8_T
|
|
AC_DEFINE_UNQUOTED(LINUX,1,[Define value for Linux OS])
|
|
AC_DEFINE_UNQUOTED(OPENSOLARIS,2,[Define value for OpenSolaris OS])
|
|
-case $host in
|
|
- *-*-linux*) AC_DEFINE_UNQUOTED(HOST_OS,LINUX,[Host OS])
|
|
- AC_CHECK_HEADERS([ieee1284.h],,
|
|
- AC_MSG_ERROR(( required header file ieee1284.h missing)))
|
|
- AC_CHECK_LIB([ieee1284],ieee1284_open,, AC_MSG_ERROR(Library not found),);;
|
|
-
|
|
- *-*-solaris2.*) AC_DEFINE(HOST_OS,OPENSOLARIS,[HOST OS]);;
|
|
- *-*-*) AC_MSG_ERROR( Host OS not (yet) supported) ;;
|
|
-esac
|
|
+AC_DEFINE_UNQUOTED(HOST_OS,LINUX,[Host OS])
|
|
|
|
## Variables to be exported
|
|
|