packages/libs/elfutils/patches/003-no_warnings_as_errors.patch
florian 86c99cff8e [package] elfutils: package libelf and libdw, update to 0.152
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27499 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-07-06 20:22:19 +00:00

100 lines
3.8 KiB
Diff

--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -322,7 +322,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libdw -I$(srcdir)/../libdwfl \
-I$(srcdir)/../libasm
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1)
--- a/libelf/Makefile.in
+++ b/libelf/Makefile.in
@@ -280,7 +280,7 @@ top_srcdir = @top_srcdir@
zip_LIBS = @zip_LIBS@
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I..
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1) $(am__append_2)
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -191,7 +191,7 @@ zip_LIBS = @zip_LIBS@
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. \
-I$(srcdir)/../libelf
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1) -fpic
--- a/libasm/Makefile.in
+++ b/libasm/Makefile.in
@@ -240,7 +240,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(top_srcdir)/libelf -I$(top_srcdir)/libebl \
-I$(top_srcdir)/libdw
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1)
--- a/libcpu/Makefile.in
+++ b/libcpu/Makefile.in
@@ -209,7 +209,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libelf -I$(srcdir)/../libebl \
-I$(srcdir)/../libdw -I$(srcdir)/../libasm
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1) -fpic -fdollars-in-identifiers
--- a/libdw/Makefile.in
+++ b/libdw/Makefile.in
@@ -284,7 +284,7 @@ zip_LIBS = @zip_LIBS@
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. \
-I$(srcdir)/../libelf
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1) $(am__append_2)
--- a/libdwfl/Makefile.in
+++ b/libdwfl/Makefile.in
@@ -275,7 +275,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libelf -I$(srcdir)/../libebl \
-I$(srcdir)/../libdw
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1)
--- a/libebl/Makefile.in
+++ b/libebl/Makefile.in
@@ -236,7 +236,7 @@ INCLUDES = -I. -I$(srcdir) -I$(top_srcdi
-I$(srcdir)/../libelf -I$(srcdir)/../libdw \
-I$(srcdir)/../libasm
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1) -fpic
--- a/tests/Makefile.in
+++ b/tests/Makefile.in
@@ -463,7 +463,7 @@ top_srcdir = @top_srcdir@
zip_LIBS = @zip_LIBS@
INCLUDES = -I. -I$(srcdir) -I$(top_srcdir)/lib -I.. $(am__append_2)
AM_CFLAGS = -std=gnu99 -Wall -Wshadow $(if \
- $($(*F)_no_Werror),,-Werror) $(if \
+ $($(*F)_no_Werror),,) $(if \
$($(*F)_no_Wunused),,-Wunused $(WEXTRA)) $(if \
$($(*F)_no_Wformat),-Wno-format,-Wformat=2) $($(*F)_CFLAGS) \
$(am__append_1)