packages/net/freeswitch/patches/009-src-mod-codecs-mod_silk-Makefile.patch
mazilo 6d1ade36a1 bumped up to the latest FS git commit (84d029e4b92c5161aca2c6317f3ff1087c60d52a)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28720 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-11-03 10:51:09 +00:00

16 lines
605 B
Diff

--- a/src/mod/codecs/mod_silk/Makefile
+++ b/src/mod/codecs/mod_silk/Makefile
@@ -1,4 +1,5 @@
BASE=../../../..
+include $(BASE)/build/openwrt_rules.mk
SILK_DIR=$(switch_srcdir)/libs/silk
SILK_BUILDDIR=$(switch_builddir)/libs/silk
LOCAL_CFLAGS=-I$(SILK_DIR)/src -I$(SILK_DIR)/interface
@@ -7,5 +8,5 @@ LOCAL_LIBADD=$(SILK_LA)
include $(BASE)/build/modmake.rules
$(SILK_LA): $(SILK_DIR)/.update
- cd $(SILK_BUILDDIR) && ./configure --disable-shared && make clean && $(MAKE)
+ cd $(SILK_BUILDDIR) && ./configure --host=$(GNU_TARGET_NAME) --disable-shared && make clean && $(MAKE)
$(TOUCH_TARGET)