5ac8a65006
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27928 3c298f89-4303-0410-b956-a3cf2f4a3e73
17 lines
494 B
Diff
17 lines
494 B
Diff
--- a/src/mod/event_handlers/mod_snmp/Makefile
|
|
+++ b/src/mod/event_handlers/mod_snmp/Makefile
|
|
@@ -1,7 +1,10 @@
|
|
-include ../../../../build/modmake.rules
|
|
+BASE=../../../..
|
|
+
|
|
+include $(BASE)/build/modmake.rules
|
|
+include $(BASE)/../../../rules.mk
|
|
+
|
|
+LOCAL_CFLAGS=$(shell $(STAGING_DIR)/host/bin/net-snmp-config --cflags --agent-libs) -DNETSNMP_NO_INLINE
|
|
|
|
-LOCAL_CFLAGS=`net-snmp-config --cflags`
|
|
-LOCAL_LDFLAGS=`net-snmp-config --agent-libs`
|
|
LOCAL_OBJS=subagent.o
|
|
|
|
local_depend: $(LOCAL_OBJS)
|