packages/lang/erlang/patches/101-emulator_includes.patch
tripolar 8072c13397 This fixes the Erlang package so that libraries for Erlang can easily be
packaged for OpenWRT. 

This means:

- static libraries and include files for compiling NIFs are copied in the
build environment to usr/{lib,include}

- crypto is enabled in host Erlang build so that rebar can be used without
further patching 

Version is bumped and 101-emulator_includes.patch is modified so that R16B02
compiles correctly.

Signed-off-by: Barnabás Králik <kralikba@msn.com <mailto:kralikba@msn.com> >


git-svn-id: svn://svn.openwrt.org/openwrt/packages@38817 3c298f89-4303-0410-b956-a3cf2f4a3e73
2013-11-15 16:25:14 +00:00

12 lines
279 B
Diff

--- a/erts/emulator/Makefile.in
+++ b/erts/emulator/Makefile.in
@@ -591,7 +591,7 @@ endif
$(OBJDIR)/%.o: beam/%.c
- $(V_CC) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) $(INCLUDES) -c $< -o $@
+ $(V_CC) $(INCLUDES) $(subst -O2, $(GEN_OPT_FLGS), $(CFLAGS)) -c $< -o $@
else