packages/net/e169-stats/patches/01-make.patch
florian a876275450 e169-stats: rework makefile patch to be more general
Allow the makefile patch to pass CFLAGS, CPPFLAGS, and LDFLAGS

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39803 3c298f89-4303-0410-b956-a3cf2f4a3e73
2014-03-08 00:56:45 +00:00

12 lines
247 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -1,7 +1,7 @@
all: e169-stats
e169-stats: e169-stats.c
- gcc -Wall -o e169-stats e169-stats.c -lcurses
+ $(CC) $(CFLAGS) -Wall -o e169-stats e169-stats.c $(CPPFLAGS) $(LDFLAGS)
clean:
-rm e169-stats *.core