fc2620d483
All the testing utilities were not using our CFLAGS or CXXFLAGS fix that. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39867 3c298f89-4303-0410-b956-a3cf2f4a3e73
28 lines
1015 B
Diff
28 lines
1015 B
Diff
--- a/testing/Makefile
|
|
+++ b/testing/Makefile
|
|
@@ -1,19 +1,19 @@
|
|
all: randchars randprintable test_speed-kernel test_speed-userspace match_kernel
|
|
|
|
randchars: randchars.c
|
|
- gcc -O2 -o randchars randchars.c
|
|
+ $(CC) $(CFLAGS) -o randchars randchars.c
|
|
|
|
randprintable: randprintable.c
|
|
- gcc -O2 -o randprintable randprintable.c
|
|
+ $(CC) $(CFLAGS) -o randprintable randprintable.c
|
|
|
|
test_speed-kernel: test_speed-kernel.c
|
|
- gcc -o test_speed-kernel test_speed-kernel.c
|
|
+ $(CC) $(CFLAGS) -o test_speed-kernel test_speed-kernel.c
|
|
|
|
test_speed-userspace: test_speed-userspace.cpp l7-parse-patterns.cpp l7-parse-patterns.h
|
|
- g++ -Wall -o test_speed-userspace test_speed-userspace.cpp l7-parse-patterns.cpp
|
|
+ $(CXX) $(CXXFLAGS) -Wall -o test_speed-userspace test_speed-userspace.cpp l7-parse-patterns.cpp
|
|
|
|
match_kernel: match-kernel.c
|
|
- gcc -O2 -o match_kernel match-kernel.c
|
|
+ $(CC) $(CFLAGS) -o match_kernel match-kernel.c
|
|
|
|
clean:
|
|
rm -f randprintable randchars test_speed-kernel test_speed-userspace match_kernel
|