977de77cc1
We were failing the build w/ GCC 4.8 on the sysconf() prototype due to a missing include of unistd.h Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39922 3c298f89-4303-0410-b956-a3cf2f4a3e73
14 lines
621 B
Diff
14 lines
621 B
Diff
--- a/builders/make/linux.mk
|
|
+++ b/builders/make/linux.mk
|
|
@@ -31,8 +31,8 @@ OPTIMIZATIONS = -O3
|
|
COMPILE_FLAGS = $(FPIC) $(OPTIMIZATIONS) $(CFLAGS)
|
|
|
|
#linking flags
|
|
-dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,"\$$ORIGIN"
|
|
-dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,"\$$ORIGIN"
|
|
+dynamic_lib_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-soname,$(DYNAMIC_LIB_PREFIX)$(1)$(DYNAMIC_LIB_SUFIX) -Wl,-rpath,/usr/lib/crtmpserver
|
|
+dynamic_exec_flags = $(FPIC) $(OPTIMIZATIONS) -Wl,-rpath,/usr/lib/crtmpserver
|
|
|
|
#compile switches
|
|
PLATFORM_DEFINES = \
|