packages/libs/st2205tool/patches/100-base-makefile.patch
thepeople 067c525db2 this library is useful for hacked picframe displays. you can use this lib also with lcd4linux. Signed-off-by: Michael Vogt <michu at neophob.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11068 3c298f89-4303-0410-b956-a3cf2f4a3e73
2008-05-08 01:17:42 +00:00

38 lines
852 B
Diff

--- st2205tool/Makefile.orig 2008-01-22 00:43:38.000000000 +0100
+++ st2205tool/Makefile 2008-04-22 16:01:46.000000000 +0200
@@ -6,26 +6,26 @@
all: libst2205/libst2205.so setpic/setpic phack splice bgrep
install: all
- make -C libst2205 install
+ $(MAKE) -C libst2205 install
libst2205/libst2205.so:
- make -C libst2205
+ $(MAKE) -C libst2205
setpic/setpic:
- make -C setpic
+ $(MAKE) -C setpic
phack: $(OBJ) $(SRC)
- gcc -o $(@) $(OBJ) $(LIBS) $(FLAGS)
+ $(GCC) -o $(@) $(OBJ) $(LIBS) $(FLAGS)
splice: splice.o splice.c
- gcc -o splice splice.o
+ $(GCC) -o splice splice.o
bgrep: bgrep.o bgrep.c
- gcc -o bgrep bgrep.o
+ $(GCC) -o bgrep bgrep.o
clean:
- make -C libst2205 clean
- make -C setpic clean
+ $(MAKE) -C libst2205 clean
+ $(MAKE) -C setpic clean
rm -f $(OBJ) phack splice splice.o bgrep bgrep.o
distclean: clean