0c4ed19f02
I've managed to update Snort to version 2.9.2.2. I did not want to split this patch even if it has so many deltas - there are many deletions of unused patches. Also there is a configuration file that has almost the same functionality as the 2.8.4.1 one. The reason I've not written a patch for update to 2.9.3 is to preserve compatibility with snortsam which has not patch for 2.9.3 yet. If this patch becomes accepted then patch http://patchwork.openwrt.org/patch/2381/ becomes obsolete, because it depends on 2.8.4.1. Next patch (3/3) introduces support for Snortsam package (Snortsam is snort version independent, just needs snort to be patched with proper patch). Signed-off-by: Jiri Slachta <jiri@slachta.eu> git-svn-id: svn://svn.openwrt.org/openwrt/packages@33169 3c298f89-4303-0410-b956-a3cf2f4a3e73
41 lines
939 B
Diff
41 lines
939 B
Diff
--- a/configure.in
|
|
+++ b/configure.in
|
|
@@ -283,21 +283,22 @@ AC_CHECK_TYPES([int8_t,int16_t,int32_t,i
|
|
AC_CHECK_TYPES([boolean])
|
|
|
|
# In case INADDR_NONE is not defined (like on Solaris)
|
|
-have_inaddr_none="no"
|
|
-AC_MSG_CHECKING([for INADDR_NONE])
|
|
-AC_RUN_IFELSE(
|
|
-[AC_LANG_PROGRAM(
|
|
-[[
|
|
-#include <sys/types.h>
|
|
-#include <netinet/in.h>
|
|
-#include <arpa/inet.h>
|
|
-]],
|
|
-[[
|
|
- if (inet_addr("10,5,2") == INADDR_NONE);
|
|
- return 0;
|
|
-]])],
|
|
-[have_inaddr_none="yes"],
|
|
-[have_inaddr_none="no"])
|
|
+have_inaddr_none="yes"
|
|
+#AC_MSG_CHECKING([for INADDR_NONE])
|
|
+#AC_RUN_IFELSE(
|
|
+#[AC_LANG_PROGRAM(
|
|
+#[[
|
|
+##include <sys/types.h>
|
|
+##include <netinet/in.h>
|
|
+##include <arpa/inet.h>
|
|
+#]],
|
|
+#[[
|
|
+# if (inet_addr("10,5,2") == INADDR_NONE);
|
|
+# return 0;
|
|
+#]])],
|
|
+#[have_inaddr_none="yes"],
|
|
+#[have_inaddr_none="yes"])
|
|
+
|
|
AC_MSG_RESULT($have_inaddr_none)
|
|
if test "x$have_inaddr_none" = "xno"; then
|
|
AC_DEFINE([INADDR_NONE],[-1],[For INADDR_NONE definition])
|