packages/ipv6/aiccu/patches/100-cross_compile.patch
florian f0711b5b0f Update aiccu to 20070115 (#1211)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6124 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-01-18 14:10:56 +00:00

102 lines
3.6 KiB
Diff

diff -urN aiccu/unix-console/Makefile aiccu.new/unix-console/Makefile
--- aiccu/unix-console/Makefile 2007-01-15 12:04:27.000000000 +0100
+++ aiccu.new/unix-console/Makefile 2007-01-18 15:08:28.000000000 +0100
@@ -10,6 +10,9 @@
# $Date: 2007-01-15 11:04:27 $
# **********************************************************/
+OS_NAME=$(shell uname)
+OS_VERSION=$(shell uname -r)
+
SRCS = main.c ../common/tun.c ../common/aiccu.c ../common/hash_md5.c ../common/hash_sha1.c ../common/common.c ../common/heartbeat.c ../common/tic.c ../common/ayiya.c ../common/aiccu_test.c ../common/resolver.c
INCS = ../common/tun.h ../common/aiccu.h ../common/hash_md5.h ../common/hash_sha1.h ../common/common.h ../common/heartbeat.h ../common/tic.h ../common/ayiya.h ../common/resolver.h
OBJS = main.o ../common/tun.o ../common/aiccu.o ../common/hash_md5.o ../common/hash_sha1.o ../common/common.o ../common/heartbeat.o ../common/tic.o ../common/ayiya.o ../common/aiccu_test.o ../common/resolver.o
@@ -40,13 +43,13 @@
# GnuTLS Support ?
# Used by TIC to secure that communication
# Currently defaultly builds only on Linux, but other platforms might easily also support it
-ifeq ($(shell uname | grep -c "Linux"),1)
+ifneq ($(HAEVE_GNUTLS),)
CFLAGS += -D AICCU_GNUTLS
LDFLAGS += -lgnutls
endif
# Linux
-ifeq ($(shell uname | grep -c "Linux"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "Linux"),1)
CFLAGS += -D_LINUX -D HAS_IFHEAD -D AICCU_TYPE="\"linux\""
SRCS += ../common/aiccu_linux.c
OBJS += ../common/aiccu_linux.o
@@ -54,11 +57,11 @@
endif
# FreeBSD
-ifeq ($(shell uname | grep -c "FreeBSD"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "FreeBSD"),1)
CFLAGS += -D_FREEBSD
# FreeBSD 4.x
-ifeq ($(shell uname -r | cut -c 1),4)
+ifeq ($(shell echo $(OS_VERSION) | cut -c 1),4)
CFLAGS += -D AICCU_TYPE="\"freebsd4\""
SRCS += ../common/aiccu_freebsd4.c
OBJS += ../common/aiccu_freebsd4.o
@@ -71,7 +74,7 @@
endif
# DragonFlyBSD
-ifeq ($(shell uname | grep -c "DragonFly"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "DragonFly"),1)
CFLAGS += -D_DFBSD -D NEED_IFHEAD -D AICCU_TYPE="\"dragonfly\""
SRCS += ../common/aiccu_freebsd4.c
OBJS += ../common/aiccu_freebsd4.o
@@ -79,7 +82,7 @@
endif
# NetBSD
-ifeq ($(shell uname | grep -c "NetBSD"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "NetBSD"),1)
CFLAGS += -D_NETBSD -D AICCU_TYPE="\"kame\""
# Check if net/if_tun.h has TUNSIFHEAD and enable support for it
@@ -97,10 +100,10 @@
endif
# OpenBSD
-ifeq ($(shell uname | grep -c "OpenBSD"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "OpenBSD"),1)
CFLAGS += -D_OPENBSD -D HAS_IFHEAD
# 2.7-2.9
-ifeq ($(shell uname -r | cut -c 1),2)
+ifeq ($(shell echo $(OS_VERSION) | cut -c 1),2)
CFLAGS += -D AICCU_TYPE="\"openbsd2\""
SRCS += ../common/aiccu_openbsd2.c
OBJS += ../common/aiccu_openbsd2.o
@@ -114,7 +117,7 @@
endif
# Darwin
-ifeq ($(shell uname | grep -c "Darwin"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "Darwin"),1)
CFLAGS += -D_DARWIN -D NEED_IFHEAD -D AICCU_TYPE="\"darwin\""
SRCS += ../common/aiccu_darwin.c
OBJS += ../common/aiccu_darwin.o
@@ -122,7 +125,7 @@
endif
# SunOS / Solaris
-ifeq ($(shell uname | grep -c "SunOS"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "SunOS"),1)
CFLAGS += -D_SUNOS -D AICCU_TYPE="\"sunos\""
SRCS += ../common/aiccu_sunos.c
OBJS += ../common/aiccu_sunos.o
@@ -130,7 +133,7 @@
endif
# AIX
-ifeq ($(shell uname | grep -c "AIX"),1)
+ifeq ($(shell echo $(OS_NAME) | grep -c "AIX"),1)
CC = @/usr/vac/bin/xlc_r
CFLAGS = -qthreaded -q64 -qlanglvl=stdc99 -bmaxdata:0xD0000000 -D_64BIT -g -qdbxextra -qfullpath -qheapdebug -qformat=all -qcheck=all
CFLAGS += -D AICCU_CONSOLE