packages/libs/libnet-1.1.x/patches/150-portability.patch
tripolar 57805c0015 [packages] libnet1: update to 1.1.6
Signed-off-by: Peter Wagner <tripolar@gmx.at>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@38707 3c298f89-4303-0410-b956-a3cf2f4a3e73
2013-11-10 18:07:16 +00:00

15 lines
423 B
Diff

--- a/configure.in
+++ b/configure.in
@@ -67,7 +67,10 @@ dnl Get link-layer interface type
dnl
AC_MSG_CHECKING(link-layer packet interface type)
-if test -r /dev/bpf0 ; then
+if test -n "$LL_INT_TYPE"; then
+ AC_LIBOBJ($LL_INT_TYPE)
+ AC_MSG_RESULT(found $LL_INT_TYPE (cached))
+elif test -r /dev/bpf0 ; then
AC_LIBOBJ([libnet_link_bpf])
AC_MSG_RESULT(found bpf)
elif test -r /usr/include/net/pfilt.h ; then