7ba23075b8
- Update socat to 1.7.2.0 (main reason: avoids compile-error against kernel 3.3.5 with ext2_fs.h which seems to got removed/changed to not being used from userspace from current kernel) - remove 502-no_sslv2.patch which doesn't apply surely and looks quite outdated to me, socat isn't linked against *ssl* anyway, compiles and works fine, verified on ar71xx Michael Signed-off-by: Michael Markstaller <mm@elabnet.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@31818 3c298f89-4303-0410-b956-a3cf2f4a3e73
13 lines
401 B
Diff
13 lines
401 B
Diff
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -38,7 +38,8 @@ INSTALL = @INSTALL@
|
|
|
|
#0 CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(INCLS)
|
|
CFLAGS = @CFLAGS@ $(CCOPTS) $(DEFS) $(CPPFLAGS)
|
|
-CLIBS = $(LIBS)
|
|
+LDFLAGS = @LDFLAGS@
|
|
+CLIBS = $(LDFLAGS) $(LIBS)
|
|
#CLIBS = $(LIBS) -lm -lefence
|
|
XIOSRCS = xioinitialize.c xiohelp.c xioparam.c xiodiag.c xioopen.c xioopts.c \
|
|
xiosignal.c xiosigchld.c xioread.c xiowrite.c \
|