packages/multimedia/motion/patches/002-honor_cppflags.patch
nico 3195d5d877 [packages] motion: update to v3.2.11.1, add dependency on libpthread, cleanup
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17944 3c298f89-4303-0410-b956-a3cf2f4a3e73
2009-10-06 03:02:53 +00:00

20 lines
764 B
Diff

--- a/Makefile.in
+++ b/Makefile.in
@@ -31,6 +31,7 @@ examplesdir = $(datadir)/@PACKAGE_NAME@-
# install. #
################################################################################
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"@PACKAGE_VERSION@\" -Dsysconfdir=\"$(sysconfdir)\"
+CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
VIDEO_OBJ = @VIDEO@
@@ -118,7 +119,7 @@ endif
################################################################################
$(DEPEND_FILE): *.h $(SRC)
@echo "Generating dependencies, please wait..."
- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
+ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
@mv -f .tmp $(DEPEND_FILE)
@echo