packages/lang/pypcap/patches/001-python2_5.patch
nico b94f02fe5f massive python changes:
* move all python packages to lang section
 * add a python-package.mk rules file sourced by all python packages for PyPackage/* defs
 * introduce a new way of specifying files to be packaged (experimental)
 * add missing svn:properties


git-svn-id: svn://svn.openwrt.org/openwrt/packages@8639 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-09-06 02:52:35 +00:00

12 lines
422 B
Diff

--- pypcap-1.1-old/pcap.pyx 2005-10-16 18:00:11.000000000 -0500
+++ pypcap-1.1/pcap.pyx 2007-06-12 11:11:41.000000000 -0500
@@ -285,7 +285,7 @@
<unsigned char *>&ctx)
if ctx.got_exc:
exc = sys.exc_info()
- raise exc[0], exc[1], exc[2]
+ raise OSError, "%s [%s]" % (exc[0], exc[1]), exc[2]
return n
def loop(self, callback, *args):