packages/lang/ruby/patches/100-Makefile-in.patch
olli 49d2200fe9 ruby:
* Update: 1.8.5-p12 > 1.8.6
 * Split into ruby and libruby packages
 * Add patches to make ruby compile
 * Cleanup Makefile

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8004 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-07-16 13:15:11 +00:00

14 lines
449 B
Diff

Index: ruby-1.8.6/Makefile.in
===================================================================
--- ruby-1.8.6.orig/Makefile.in 2007-07-16 15:10:57.000000000 +0200
+++ ruby-1.8.6/Makefile.in 2007-07-16 15:10:58.000000000 +0200
@@ -131,7 +131,7 @@
if RUBY_PLATFORM =~ /mswin|bccwin|mingw/; \
class File; \
remove_const :ALT_SEPARATOR; \
- ALT_SEPARATOR = "\\"; \
+ ALT_SEPARATOR = "\\\\"; \
end; \
end; \
' > $@