packages/multimedia/motion/patches/002-honor_cppflags.patch
pavlov 14c1a8db5f patch file cleanup... ick.. kaloz you owe me some love
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6526 3c298f89-4303-0410-b956-a3cf2f4a3e73
2007-03-05 01:34:12 +00:00

21 lines
829 B
Diff

diff -ruN motion-3.2.5.1-old/Makefile.in motion-3.2.5.1-new/Makefile.in
--- motion-3.2.5.1-old/Makefile.in 2006-03-07 22:52:49.000000000 +0100
+++ motion-3.2.5.1-new/Makefile.in 2006-03-27 22:04:34.000000000 +0200
@@ -32,6 +32,7 @@
################################################################################
CFLAGS = @CFLAGS@ -Wall -DVERSION=\"$(VERSION)\" -D_REENTRANT \
-Dsysconfdir=\"$(sysconfdir)\"
+CPPFLAGS = @CPPFLAGS@
LDFLAGS = @LDFLAGS@
LIBS = @LIBS@
VIDEO_OBJ = @VIDEO@
@@ -115,7 +116,7 @@
################################################################################
$(DEPEND_FILE): *.h $(SRC)
@echo "Generating dependencies, please wait..."
- @$(CC) $(CFLAGS) -M $(SRC) > .tmp
+ @$(CC) $(CFLAGS) $(CPPFLAGS) -M $(SRC) > .tmp
@mv -f .tmp $(DEPEND_FILE)
@echo