packages/utils/smartmontools/patches/01-compile-fix.patch
florian 4b2601d406 Add smartmontools (#1066)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5907 3c298f89-4303-0410-b956-a3cf2f4a3e73
2006-12-27 19:08:15 +00:00

30 lines
1.5 KiB
Diff

--- smartmontools-5.36/configure.in.orig 2006-12-17 03:01:38.000000000 +0100
+++ smartmontools-5.36/configure.in 2006-12-17 03:00:35.000000000 +0100
@@ -74,16 +74,16 @@
AC_CHECK_FUNCS([uname])
# Check whether snprintf appends null char and returns expected length on overflow
-AH_TEMPLATE(HAVE_WORKING_SNPRINTF, [Define to 1 if the `snprintf' function is sane])
-AC_MSG_CHECKING([for working snprintf])
-AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[ char buf[]="ABCDEFGHI";
- int i=snprintf(buf,8,"12345678"); return !(!buf[7] && i==8); ]])],
- [libc_have_working_snprintf=yes], [libc_have_working_snprintf=no])
-AC_SUBST(libc_have_working_snprintf)
-if test "$libc_have_working_snprintf" = "yes"; then
- AC_DEFINE(HAVE_WORKING_SNPRINTF)
-fi
-AC_MSG_RESULT([$libc_have_working_snprintf])
+#AH_TEMPLATE(HAVE_WORKING_SNPRINTF, [Define to 1 if the `snprintf' function is sane])
+#AC_MSG_CHECKING([for working snprintf])
+#AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[ char buf[]="ABCDEFGHI";
+# int i=snprintf(buf,8,"12345678"); return !(!buf[7] && i==8); ]])],
+# [libc_have_working_snprintf=yes], [libc_have_working_snprintf=no])
+#AC_SUBST(libc_have_working_snprintf)
+#if test "$libc_have_working_snprintf" = "yes"; then
+# AC_DEFINE(HAVE_WORKING_SNPRINTF)
+#fi
+#AC_MSG_RESULT([$libc_have_working_snprintf])
# check for __attribute__((packed))
AH_TEMPLATE(HAVE_ATTR_PACKED, [Define to 1 if C compiler supports __attribute__((packed))])