packages/net/openl2tp/patches/002-no_libfl.patch
nico 07a3a1c232 packages/openl2tp: enable config file support (thanks to Bogdan Roman), provide -full & -mini variants (closes: #10164)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28758 3c298f89-4303-0410-b956-a3cf2f4a3e73
2011-11-04 23:28:07 +00:00

23 lines
414 B
Diff

--- a/l2tp_config_token.l
+++ b/l2tp_config_token.l
@@ -23,6 +23,8 @@ static int resolveip(const char *val, st
int lineno;
int command;
+int yywrap(void) { return 1; }
+
%}
/* common section */
--- a/Makefile
+++ b/Makefile
@@ -204,7 +204,7 @@ ifeq ($(L2TP_FEATURE_LOCAL_CONF_FILE),y)
# Config file parser
LEX= flex
YACC= bison
-LDFLAGS.l2tpd+= -lfl
+LDFLAGS.l2tpd+=
%.c: %.l
$(LEX) -o$@ $<