977de77cc1
We were failing the build w/ GCC 4.8 on the sysconf() prototype due to a missing include of unistd.h Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39922 3c298f89-4303-0410-b956-a3cf2f4a3e73
12 lines
324 B
Diff
12 lines
324 B
Diff
--- a/builders/make/compile.mk
|
|
+++ b/builders/make/compile.mk
|
|
@@ -59,7 +59,7 @@ DEFINES = $(PLATFORM_DEFINES) $(FEATURES
|
|
|
|
#library paths
|
|
SSL_INCLUDE=-I$(SSL_BASE)/include
|
|
-SSL_LIB=-L$(SSL_BASE)/lib -lssl -lcrypto
|
|
+SSL_LIB=-L$(SSL_BASE)/lib -lssl -lcrypto -ldl
|
|
|
|
#lua
|
|
LUA_INCLUDE=-I$(PROJECT_BASE_PATH)/3rdparty/lua-dev
|