packages/multimedia/crtmpserver/patches/060-add-dl-for-crypto.patch
florian 977de77cc1 crtmpsever: add missing unistd.h inclusion for sysconf()
We were failing the build w/ GCC 4.8 on the sysconf() prototype due to a
missing include of unistd.h

Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39922 3c298f89-4303-0410-b956-a3cf2f4a3e73
2014-03-13 16:52:13 +00:00

12 lines
324 B
Diff

--- a/builders/make/compile.mk
+++ b/builders/make/compile.mk
@@ -59,7 +59,7 @@ DEFINES = $(PLATFORM_DEFINES) $(FEATURES
#library paths
SSL_INCLUDE=-I$(SSL_BASE)/include
-SSL_LIB=-L$(SSL_BASE)/lib -lssl -lcrypto
+SSL_LIB=-L$(SSL_BASE)/lib -lssl -lcrypto -ldl
#lua
LUA_INCLUDE=-I$(PROJECT_BASE_PATH)/3rdparty/lua-dev