fix lirc compile and move its build dir to the right place

git-svn-id: svn://svn.openwrt.org/openwrt/packages@12158 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nbd 2008-08-05 20:49:28 +00:00
parent 2771b099fb
commit 04ed50d2e1
2 changed files with 17 additions and 1 deletions

View File

@ -18,7 +18,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/${PKG_NAME}
PKG_MD5SUM:=8e78eeded7b31e5ad02e328970437c0f
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk

View File

@ -0,0 +1,16 @@
--- a/drivers/kcompat.h
+++ b/drivers/kcompat.h
@@ -53,7 +53,13 @@
#else /* >= 2.6.15 */
+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,25)
+#define lirc_class_device_create device_create_drvdata
+#define class_device_destroy device_destroy
+#else
#define lirc_class_device_create class_device_create
+#endif
+
#define LIRC_DEVFS_PREFIX
#endif