[packages] vsftpd: fix compilation if libcap has been built in the same tree (#10937)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@30941 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-03-14 18:42:09 +00:00
parent f0877c8c3b
commit 066f726437
3 changed files with 15 additions and 3 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2006-2011 OpenWrt.org
# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=vsftpd
PKG_VERSION:=2.3.4
PKG_RELEASE:=3
PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://security.appspot.com/downloads/

View File

@ -1,6 +1,6 @@
--- a/tunables.c
+++ b/tunables.c
@@ -244,7 +244,7 @@ tunables_load_defaults()
@@ -250,7 +250,7 @@ tunables_load_defaults()
/* -rw------- */
tunable_chown_upload_mode = 0600;

View File

@ -0,0 +1,12 @@
--- a/sysdeputil.c
+++ b/sysdeputil.c
@@ -165,6 +165,9 @@
#endif
/* END config */
+#undef VSF_SYSDEP_HAVE_CAPABILITIES
+#undef VSF_SYSDEP_HAVE_LIBCAP
+
/* PAM support - we include our own dummy version if the system lacks this */
#include <security/pam_appl.h>