[package] update gpsd to 2.39, use uclibc++ and remove obsolete patches, patch from Roberto Riggio
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17001 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
30afec1952
commit
06f1eb2673
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006,2008 OpenWrt.org
|
||||
# Copyright (C) 2006,2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,14 +8,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gpsd
|
||||
PKG_VERSION:=2.37
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=2.39
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://download.berlios.de/gpsd/
|
||||
PKG_MD5SUM:=6c96cc0b2df0279cb7baac1ebc5881d3
|
||||
PKG_MD5SUM:=3db437196a6840c252fca99b6c19d4d0
|
||||
|
||||
PKG_FIXUP = libtool
|
||||
PKG_FIXUP:=libtool-ucxx
|
||||
|
||||
PKG_BUILD_DEPENDS=libncurses
|
||||
|
||||
@ -24,30 +24,29 @@ include $(INCLUDE_DIR)/package.mk
|
||||
define Package/gpsd
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpthread +libstdcpp
|
||||
DEPENDS:=+libpthread +uclibcxx
|
||||
TITLE:=An interface daemon for GPS receivers
|
||||
URL:=http://gpsd.berlios.de/
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-dbus \
|
||||
--disable-python \
|
||||
--disable-sirf \
|
||||
--disable-tsip \
|
||||
--disable-fv18 \
|
||||
--disable-tripmate \
|
||||
--disable-earthmate \
|
||||
--disable-itrax \
|
||||
--disable-navcom \
|
||||
--disable-garmin \
|
||||
--disable-ubx \
|
||||
--disable-evermore \
|
||||
--disable-rtcm104 \
|
||||
--disable-ntrip \
|
||||
--disable-ntpshm \
|
||||
--disable-pps \
|
||||
--disable-reconfigure \
|
||||
--without-x \
|
||||
--disable-dbus \
|
||||
--disable-tsip \
|
||||
--disable-fv18 \
|
||||
--disable-tripmate \
|
||||
--disable-earthmate \
|
||||
--disable-itrax \
|
||||
--disable-navcom \
|
||||
--disable-ubx \
|
||||
--disable-evermore \
|
||||
--disable-ntrip \
|
||||
--without-x \
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
|
||||
LDFLAGS="$$$$LDFLAGS" \
|
||||
LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
|
@ -1,26 +0,0 @@
|
||||
--- a/gpsd.c
|
||||
+++ b/gpsd.c
|
||||
@@ -42,6 +42,7 @@
|
||||
#include <locale.h>
|
||||
#endif
|
||||
|
||||
+#undef DBUS_ENABLE
|
||||
#ifdef DBUS_ENABLE
|
||||
#include <gpsd_dbus.h>
|
||||
#endif
|
||||
@@ -297,6 +298,7 @@
|
||||
* This array fills from the bottom, so as an extreme case you could
|
||||
* reduce LIMITED_MAX_DEVICES to 1.
|
||||
*/
|
||||
+#define LIMITED_MAX_DEVICES 1
|
||||
#ifdef LIMITED_MAX_DEVICES
|
||||
#define MAXDEVICES LIMITED_MAX_DEVICES
|
||||
#else
|
||||
@@ -304,6 +306,7 @@
|
||||
#define MAXDEVICES 4
|
||||
#endif
|
||||
|
||||
+#define LIMITED_MAX_CLIENTS 16
|
||||
#ifdef LIMITED_MAX_CLIENTS
|
||||
#define MAXSUBSCRIBERS LIMITED_MAX_CLIENTS
|
||||
#else
|
@ -1,40 +0,0 @@
|
||||
--- a/drivers.c
|
||||
+++ b/drivers.c
|
||||
@@ -202,9 +202,13 @@
|
||||
/* probe for the FV-18 -- expect $PFEC,GPint followed by data */
|
||||
(void)nmea_send(session->gpsdata.gps_fd, "$PFEC,GPint");
|
||||
break;
|
||||
+ case 3:
|
||||
+ /* probe for the Trimble Copernicus */
|
||||
+ (void)nmea_send(session->gpsdata.gps_fd, "$PTNLSNM,0139,01");
|
||||
+ break;
|
||||
#endif /* NMEA_ENABLE */
|
||||
#ifdef EVERMORE_ENABLE
|
||||
- case 3:
|
||||
+ case 4:
|
||||
/* Enable checksum and GGA(1s), GLL(0s), GSA(1s), GSV(1s), RMC(1s), VTG(0s), PEMT101(1s) */
|
||||
/* EverMore will reply with: \x10\x02\x04\x38\x8E\xC6\x10\x03 */
|
||||
(void)gpsd_write(session,
|
||||
@@ -212,19 +216,19 @@
|
||||
break;
|
||||
#endif /* EVERMORE_ENABLE */
|
||||
#ifdef ITRAX_ENABLE
|
||||
- case 4:
|
||||
+ case 5:
|
||||
/* probe for iTrax, looking for "$PFST,OK" */
|
||||
(void)nmea_send(session->gpsdata.gps_fd, "$PFST");
|
||||
break;
|
||||
#endif /* ITRAX_ENABLE */
|
||||
#ifdef GPSCLOCK_ENABLE
|
||||
- case 5:
|
||||
+ case 6:
|
||||
/* probe for Furuno Electric GH-79L4-N (GPSClock) */
|
||||
(void)nmea_send(session->gpsdata.gps_fd, "$PFEC,GPsrq");
|
||||
break;
|
||||
#endif /* GPSCLOCK_ENABLE */
|
||||
#ifdef ASHTECH_ENABLE
|
||||
- case 6:
|
||||
+ case 7:
|
||||
/* probe for Ashtech -- expect $PASHR */
|
||||
(void)nmea_send(session->gpsdata.gps_fd, "$PASHQ,RID");
|
||||
break;
|
Loading…
x
Reference in New Issue
Block a user