mdnsresponder: ensure dns-sd is linked with the right options
Some toolchains (e.g: ARM with VFP) require us to specify the ABI to use, update the dns-sd linking command-line for this. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@39811 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0014d62691
commit
0918445fde
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2009-2011 OpenWrt.org
|
||||
# Copyright (C) 2009-2014 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mDNSResponder
|
||||
PKG_VERSION:=544
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
|
||||
|
@ -14,11 +14,11 @@
|
||||
|
||||
build/dns-sd: build dns-sd.c ClientCommon.c
|
||||
- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
|
||||
+ $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
|
||||
+ $(CC) $(CFLAGS) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@
|
||||
|
||||
build/dns-sd64: build dns-sd.c ClientCommon.c
|
||||
- cc $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
|
||||
+ $(CC) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
|
||||
+ $(CC) $(CFLAGS) $(filter %.c %.o, $+) $(LIBS) -I../mDNSShared -Wall -o $@ -m64
|
||||
|
||||
# Note, we can make a 'fat' version of dns-sd using 'lipo', as shown below, but we
|
||||
# don't, because we don't want or need a 'fat' version of dns-sd, because it will
|
||||
@ -56,7 +56,7 @@
|
||||
LINKOPTS = -lsocket -lnsl -lresolv
|
||||
JAVACFLAGS_OS += -I$(JDK)/include/solaris
|
||||
ifneq ($(DEBUG),1)
|
||||
@@ -147,7 +148,8 @@ CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp
|
||||
@@ -147,7 +148,8 @@ CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp
|
||||
-D__MAC_OS_X_VERSION_MIN_REQUIRED=__MAC_OS_X_VERSION_10_4 \
|
||||
-D__APPLE_USE_RFC_2292 #-Wunreachable-code
|
||||
CC = gcc
|
||||
|
@ -11,9 +11,6 @@ places and mdnsd is quite confused.
|
||||
1 file changed, 22 insertions(+)
|
||||
create mode 100644 net/mdnsresponder/patches/003-ipv6-bind-to-interface.patch
|
||||
|
||||
diff --git a/net/mdnsresponder/patches/003-ipv6-bind-to-interface.patch b/net/mdnsresponder/patches/003-ipv6-bind-to-interface.patch
|
||||
new file mode 100644
|
||||
index 0000000..c65221e
|
||||
--- /dev/null
|
||||
+++ b/net/mdnsresponder/patches/003-ipv6-bind-to-interface.patch
|
||||
@@ -0,0 +1,22 @@
|
||||
@ -39,6 +36,3 @@ index 0000000..c65221e
|
||||
+ if (err == 0)
|
||||
+ {
|
||||
+Only in mDNSResponder-544/mDNSPosix: mDNSPosix.c~
|
||||
--
|
||||
1.7.9.5
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user