git-svn-id: svn://svn.openwrt.org/openwrt/packages@22693 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1d4c6edc0c
commit
0e9c472232
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=openswan
|
||||
PKG_VERSION:=2.6.25
|
||||
PKG_VERSION:=2.6.28
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.openswan.org/download
|
||||
PKG_MD5SUM:=c1223786c9eb58950a4be0ab2d0a84d1
|
||||
PKG_MD5SUM:=37f2ad2664dd89e6ad96ae82f6378166
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -17,14 +17,3 @@
|
||||
then
|
||||
echo Cannot write to directory to create \"$stderrlog\".
|
||||
exit 1
|
||||
--- a/programs/_realsetup/_realsetup.in
|
||||
+++ b/programs/_realsetup/_realsetup.in
|
||||
@@ -282,7 +282,7 @@ case "$1" in
|
||||
|
||||
# misc pre-Pluto setup
|
||||
|
||||
- perform test -d `dirname $subsyslock` "&&" touch $subsyslock
|
||||
+ perform test -d `echo $subsyslock | sed -r 's/(^.*\/)(.*$)/\1/'` "&&" touch $subsyslock "&&" rm -f $subsyslock
|
||||
|
||||
manualconns
|
||||
|
||||
|
@ -22,7 +22,7 @@
|
||||
-
|
||||
--- a/programs/pluto/Makefile
|
||||
+++ b/programs/pluto/Makefile
|
||||
@@ -188,35 +188,11 @@ doinstall: all
|
||||
@@ -191,35 +191,11 @@ doinstall: all
|
||||
$(INSTALL) $(INSTBINFLAGS) $(BINNAMEPLUTO) $(BINNAMEWHACK) $(LIBEXECDIR)
|
||||
#$(INSTALL) $(INSTSUIDFLAGS) $(BINNAMEWHACKINIT) $(LIBEXECDIR)
|
||||
if $(USE_ADNS) ; then $(INSTALL) $(INSTBINFLAGS) $(BINNAMEADNS) $(LIBEXECDIR) ; fi
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- a/linux/include/openswan/ipsec_kversion.h
|
||||
+++ b/linux/include/openswan/ipsec_kversion.h
|
||||
@@ -351,6 +351,12 @@
|
||||
# define HAVE_CURRENT_UID
|
||||
@@ -363,6 +363,12 @@
|
||||
#endif
|
||||
#endif
|
||||
|
||||
+#if LINUX_VERSION_CODE == KERNEL_VERSION(2,6,30)
|
||||
@ -11,5 +11,5 @@
|
||||
+#endif
|
||||
+
|
||||
#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,31)
|
||||
# define HAVE_SKB_DST 1
|
||||
#endif
|
||||
# define USE_NETDEV_OPS
|
||||
#else
|
||||
|
Loading…
x
Reference in New Issue
Block a user