[packages] axtls: update to 1.2.4, add new axtlswrap (SSL/TLS wrapper)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21030 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7a201ff822
commit
0f7636fa73
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2009 OpenWrt.org
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,16 +8,17 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=axtls
|
||||
PKG_VERSION:=1.2.2
|
||||
PKG_VERSION:=1.2.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=axTLS-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/axtls
|
||||
PKG_MD5SUM:=03471b5a5874e2ce86025f24b3fa0958
|
||||
PKG_MD5SUM:=4b7a6dafbe45357f63813410dae676fd
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libaxtls
|
||||
SUBMENU:=SSL
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
SUBMENU:=SSL
|
||||
@ -26,12 +27,22 @@ define Package/libaxtls
|
||||
endef
|
||||
|
||||
define Package/axhttpd
|
||||
SUBMENU:=Web
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=A small embedded web server using the axTLS library
|
||||
URL:=http://www.axtls.co.nr/
|
||||
DEPENDS:=+libaxtls
|
||||
endef
|
||||
|
||||
define Package/axtlswrap
|
||||
SUBMENU:=SSL
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=Web
|
||||
TITLE:=A simple TLS/SSL wrapper using the axTLS library
|
||||
URL:=http://sourceforge.net/projects/axtls
|
||||
DEPENDS:=+libaxtls
|
||||
TITLE:=A small embedded web server using the axTLS library
|
||||
URL:=http://www.axtls.co.nr/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
@ -69,8 +80,14 @@ endef
|
||||
|
||||
define Package/axhttpd/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/axhttpd $(1)/usr/sbin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/axhttpd $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
define Package/axtlswrap/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/_stage/axtlswrap $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libaxtls))
|
||||
$(eval $(call BuildPackage,axhttpd))
|
||||
$(eval $(call BuildPackage,axtlswrap))
|
||||
|
@ -51,6 +51,7 @@ CONFIG_USE_DEV_URANDOM=y
|
||||
# CONFIG_PERFORMANCE_TESTING is not set
|
||||
# CONFIG_SSL_TEST is not set
|
||||
CONFIG_AXHTTPD=y
|
||||
CONFIG_AXTLSWRAP=y
|
||||
|
||||
#
|
||||
# Axhttpd Configuration
|
||||
|
@ -1,6 +1,5 @@
|
||||
diff -pruN axTLS.orig/config/makefile.conf axTLS/config/makefile.conf
|
||||
--- axTLS.orig/config/makefile.conf 2009-05-20 15:27:07.425684975 +0200
|
||||
+++ axTLS/config/makefile.conf 2009-05-20 15:29:51.697489368 +0200
|
||||
--- a/config/makefile.conf
|
||||
+++ b/config/makefile.conf
|
||||
@@ -105,20 +105,23 @@ endif
|
||||
endif
|
||||
|
||||
|
@ -1,16 +1,15 @@
|
||||
diff -ru axtls-1.2.2/Makefile axtls-1.2.2-new/Makefile
|
||||
--- axtls-1.2.2/Makefile 2007-12-01 16:42:23.000000000 -0800
|
||||
+++ axtls-1.2.2-new/Makefile 2009-05-27 22:41:44.000000000 -0700
|
||||
@@ -88,8 +88,11 @@
|
||||
install: $(PREFIX) all
|
||||
cp --no-dereference $(STAGE)/libax* $(PREFIX)/lib
|
||||
chmod 755 $(PREFIX)/lib/libax*
|
||||
+ifdef CONFIG_AXHTTPD
|
||||
+ install -m 755 $(STAGE)/axhttpd $(PREFIX)/bin
|
||||
+endif
|
||||
ifdef CONFIG_SAMPLES
|
||||
- install -m 755 $(STAGE)/ax* $(PREFIX)/bin
|
||||
+ install -m 755 $(STAGE)/axssl $(PREFIX)/bin
|
||||
endif
|
||||
ifdef CONFIG_HTTP_HAS_AUTHORIZATION
|
||||
install -m 755 $(STAGE)/htpasswd $(PREFIX)/bin
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -91,8 +91,11 @@ win32_demo:
|
||||
install: $(PREFIX) all
|
||||
cp --no-dereference $(STAGE)/libax* $(PREFIX)/lib
|
||||
chmod 755 $(PREFIX)/lib/libax*
|
||||
+ifdef CONFIG_AXHTTPD
|
||||
+ install -m 755 $(STAGE)/axhttpd $(PREFIX)/bin
|
||||
+endif
|
||||
ifdef CONFIG_SAMPLES
|
||||
- install -m 755 $(STAGE)/ax* $(PREFIX)/bin
|
||||
+ install -m 755 $(STAGE)/axssl $(PREFIX)/bin
|
||||
endif
|
||||
ifdef CONFIG_HTTP_HAS_AUTHORIZATION
|
||||
install -m 755 $(STAGE)/htpasswd $(PREFIX)/bin
|
||||
|
Loading…
x
Reference in New Issue
Block a user