[packages] ahcpd: apply unreleased upstream patch
- Tue Jul 20 00:25:27 CEST 2010 Juliusz Chroboczek <jch@pps.jussieu.fr> * Fix typo -- ignore autoconf prefixes for plen > 64. - Use uci_get_state instead of invoking uci directly. Signed-off-by: Gabriel Kerneis <kerneis@pps.jussieu.fr> git-svn-id: svn://svn.openwrt.org/openwrt/packages@22309 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
cac05e988d
commit
133647f026
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=ahcpd
|
||||
PKG_VERSION:=0.51
|
||||
PKG_RELEASE:=2
|
||||
PKG_RELEASE:=3
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
|
||||
|
@ -34,9 +34,8 @@ append_opt_stmt() {
|
||||
}
|
||||
|
||||
ahcp_addif() {
|
||||
local name="$1"
|
||||
local _uciname=`uci get -q -P /var/state network.$name.ifname`
|
||||
append interfaces "${_uciname:-$name}"
|
||||
local ifname=$(uci_get_state network "$1" ifname "$1")
|
||||
append interfaces "$ifname"
|
||||
}
|
||||
|
||||
ahcp_server() {
|
||||
|
14
ipv6/ahcpd/patches/001-autoconf-prefixes.patch
Normal file
14
ipv6/ahcpd/patches/001-autoconf-prefixes.patch
Normal file
@ -0,0 +1,14 @@
|
||||
Tue Jul 20 00:25:27 CEST 2010 Juliusz Chroboczek <jch@pps.jussieu.fr>
|
||||
* Fix typo -- ignore autoconf prefixes for plen > 64.
|
||||
Thanks to Gabriel Kerneis.
|
||||
--- old-ahcpd/configure.c 2010-07-20 09:31:19.000000000 +0200
|
||||
+++ new-ahcpd/configure.c 2010-07-20 09:31:19.000000000 +0200
|
||||
@@ -505,7 +505,7 @@
|
||||
if(config->ipv6_address) {
|
||||
config->our_ipv6_address = copy_prefix_list(config->ipv6_address);
|
||||
} else if(config->ipv6_prefix && config->ipv6_prefix->n > 0 &&
|
||||
- config->ipv6_prefix->l[0].plen >= 64) {
|
||||
+ config->ipv6_prefix->l[0].plen <= 64) {
|
||||
unsigned char address[16];
|
||||
int have_address = 0;
|
||||
|
Loading…
x
Reference in New Issue
Block a user