[packages] libgcrypt: update to 1.4.5

git-svn-id: svn://svn.openwrt.org/openwrt/packages@21025 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2010-04-19 08:15:23 +00:00
parent 149d024d54
commit 164218c65c
3 changed files with 16 additions and 16 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2005-2009 OpenWrt.org
# Copyright (C) 2005-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libgcrypt
PKG_VERSION:=1.4.4
PKG_VERSION:=1.4.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.gnupg.org/gcrypt/libgcrypt/
PKG_MD5SUM:=34105aa927e23c217741966496b97e67
PKG_MD5SUM:=cc2017ad09b4543f8b3b5e9a53cfd89d
PKG_FIXUP:=libtool
PKG_INSTALL:=1
@ -39,9 +39,7 @@ define Package/libgcrypt/description
RC2, SEED, Camellia, CRC, MD4, TIGER-192, Whirlpool, ElGamal, ECC).
endef
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS+= \
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--disable-asm \
@ -50,6 +48,8 @@ CONFIGURE_ARGS+= \
--enable-ciphers="arcfour des aes" \
--enable-pubkey-ciphers="rsa dsa" \
TARGET_CFLAGS += $(FPIC)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include $(1)/usr/lib $(1)/usr/share/aclocal
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/libgcrypt-config $(1)/usr/bin/

View File

@ -1,9 +1,9 @@
The MIPS port for GCC-4.4 no longer recognizes the h asm constraint.
Patch from: https://forum.openwrt.org/viewtopic.php?id=20520
--- libgcrypt/mpi/longlong.h-asdf 2009-08-04 09:58:51.000000000 +0930
+++ libgcrypt/mpi/longlong.h 2009-08-04 10:10:27.000000000 +0930
@@ -710,18 +710,35 @@
--- a/mpi/longlong.h
+++ b/mpi/longlong.h
@@ -710,18 +710,35 @@ extern USItype __udiv_qrnnd ();
#endif /* __m88110__ */
#endif /* __m88000__ */
@ -41,7 +41,7 @@ Patch from: https://forum.openwrt.org/viewtopic.php?id=20520
#define umul_ppmm(w1, w0, u, v) \
__asm__ ("multu %2,%3 \n" \
"mflo %0 \n" \
@@ -739,14 +756,24 @@
@@ -739,14 +756,24 @@ extern USItype __udiv_qrnnd ();
************** MIPS/64 **************
***************************************/
#if (defined (__mips) && __mips >= 3) && W_TYPE_SIZE == 64

View File

@ -1,6 +1,6 @@
--- libgcrypt-1.4.4/Makefile.am~ 2008-08-19 17:20:08.000000000 +0200
+++ libgcrypt-1.4.4/Makefile.am 2009-03-18 00:13:06.000000000 +0100
@@ -22,8 +22,8 @@
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,8 +22,8 @@ AUTOMAKE_OPTIONS = dist-bzip2
DISTCHECK_CONFIGURE_FLAGS = --enable-random-daemon \
--enable-ciphers=arcfour:blowfish:cast5:des:aes:twofish:serpent:rfc2268:seed:camellia
@ -11,9 +11,9 @@
EXTRA_DIST = autogen.sh README.SVN
DISTCLEANFILES =
--- libgcrypt-1.4.4/Makefile.in~ 2009-01-22 19:16:51.000000000 +0100
+++ libgcrypt-1.4.4/Makefile.in 2009-03-18 00:13:18.000000000 +0100
@@ -237,8 +237,8 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -239,8 +239,8 @@ AUTOMAKE_OPTIONS = dist-bzip2
DISTCHECK_CONFIGURE_FLAGS = --enable-random-daemon \
--enable-ciphers=arcfour:blowfish:cast5:des:aes:twofish:serpent:rfc2268:seed:camellia