Prevent asterisk from using k6 optimisations (#1378), fixes ppc buildbot error as well
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6434 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ee40170263
commit
1943e1afcd
@ -1,38 +1,47 @@
|
||||
diff -Nru asterisk-1.2.14.org/codecs/gsm/Makefile asterisk-1.2.14/codecs/gsm/Makefile
|
||||
--- asterisk-1.2.14.org/codecs/gsm/Makefile 2006-07-24 19:05:56.000000000 +0200
|
||||
+++ asterisk-1.2.14/codecs/gsm/Makefile 2006-12-27 09:14:51.000000000 +0100
|
||||
@@ -241,6 +241,8 @@
|
||||
--- asterisk-1.2.14/codecs/gsm/Makefile.orig 2007-02-21 23:03:07.000000000 +0100
|
||||
+++ asterisk-1.2.14/codecs/gsm/Makefile 2007-02-21 23:03:40.000000000 +0100
|
||||
@@ -241,6 +241,10 @@
|
||||
ifneq ($(shell uname -m),armv4l)
|
||||
ifneq ($(shell uname -m),sparc64)
|
||||
ifneq (${PROC},arm)
|
||||
+ifneq (${PROC},armeb)
|
||||
+ifneq (${PROC},mipsel)
|
||||
+ifneq (${PROC},mips)
|
||||
+ifneq (${PROC},ppc)
|
||||
ifneq ($(shell uname -m), parisc)
|
||||
ifneq ($(shell uname -m),s390)
|
||||
GSM_SOURCES+= $(SRC)/k6opt.s
|
||||
@@ -255,6 +257,8 @@
|
||||
@@ -255,6 +258,10 @@
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
+endif
|
||||
+endif
|
||||
+endif
|
||||
+endif
|
||||
|
||||
TOAST_SOURCES = $(SRC)/toast.c \
|
||||
$(SRC)/toast_lin.c \
|
||||
@@ -308,6 +312,8 @@
|
||||
@@ -308,6 +314,11 @@
|
||||
ifneq ($(shell uname -m), alpha)
|
||||
ifneq ($(shell uname -m), sparc64)
|
||||
ifneq ($(shell uname -m), armv4l)
|
||||
+ifneq (${PROC}, arm)
|
||||
+ifneq (${PROC}, armeb)
|
||||
+ifneq (${PROC}, mipsel)
|
||||
+ifneq (${PROC}, mips)
|
||||
+ifneq (${PROC}, ppc)
|
||||
ifneq ($(shell uname -m), parisc)
|
||||
ifneq ($(shell uname -m),s390)
|
||||
GSM_OBJECTS+= $(SRC)/k6opt.o
|
||||
@@ -321,6 +327,8 @@
|
||||
@@ -321,6 +331,11 @@
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
+endif
|
||||
+endif
|
||||
+endif
|
||||
+endif
|
||||
+endif
|
||||
|
||||
TOAST_OBJECTS = $(SRC)/toast.o \
|
||||
|
Loading…
x
Reference in New Issue
Block a user