Add C++ bufgix patch from #2965, bump release number
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10094 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fb64059103
commit
1bf8ed96cc
@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=cgilib
|
||||
PKG_VERSION:=0.5
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.infodrom.org/projects/cgilib/download
|
||||
|
23
libs/cgilib/patches/300-cpp_bugfix.patch
Normal file
23
libs/cgilib/patches/300-cpp_bugfix.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff -Nur cgilib-0.5.orig/cgi.h cgilib-0.5/cgi.h
|
||||
--- cgilib-0.5.orig/cgi.h 2008-01-03 18:02:08.000000000 +0100
|
||||
+++ cgilib-0.5/cgi.h 2008-01-03 18:02:31.000000000 +0100
|
||||
@@ -20,6 +20,10 @@
|
||||
#ifndef _CGI_H_
|
||||
#define _CGI_H_
|
||||
|
||||
+#ifdef __cplusplus
|
||||
+extern "C" {
|
||||
+#endif
|
||||
+
|
||||
typedef struct var_s {
|
||||
char *name,
|
||||
*value;
|
||||
@@ -112,4 +116,8 @@
|
||||
*/
|
||||
void cgiFree (s_cgi *parms);
|
||||
|
||||
+#ifdef __cplusplus
|
||||
+} /* end of extern "C" */
|
||||
+#endif
|
||||
+
|
||||
#endif /* _CGI_H_ */
|
Loading…
x
Reference in New Issue
Block a user