fix conflicting libnet versions mess
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4899 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
faa1842465
commit
1cf6ea6e94
87
libs/libnet-1.0.x/Makefile
Normal file
87
libs/libnet-1.0.x/Makefile
Normal file
@ -0,0 +1,87 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libnet
|
||||
PKG_VERSION:=1.0.2a
|
||||
PKG_RELEASE:=7
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.packetfactory.net/libnet/dist/deprecated/
|
||||
PKG_MD5SUM:=ddf53f0f484184390e8c2a1bd0853667
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/Libnet-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libnet0
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libpcap
|
||||
TITLE:=Low-level packet creation library (v1.0.x)
|
||||
URL:=http://www.packetfactory.net/libnet/
|
||||
endef
|
||||
|
||||
ENDIANESS:=lil
|
||||
ifeq ($(ARCH),mips)
|
||||
ENDIANESS:=big
|
||||
endif
|
||||
ifeq ($(ARCH),armeb)
|
||||
ENDIANESS:=big
|
||||
endif
|
||||
ifeq ($(ARCH),powerpc)
|
||||
ENDIANESS:=big
|
||||
endif
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); touch \
|
||||
configure.in \
|
||||
include.m4 \
|
||||
aclocal.m4 \
|
||||
Makefile.in \
|
||||
configure \
|
||||
);
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--with-pf_packet=yes \
|
||||
, \
|
||||
ac_libnet_have_pf_packet=yes \
|
||||
ac_cv_lbl_unaligned_fail=no \
|
||||
ac_cv_libnet_endianess=$(ENDIANESS) \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/libnet-1.0.x/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/libnet-config $(STAGING_DIR)/usr/lib/libnet-1.0.x/bin/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/libnet-1.0.x/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libnet* $(STAGING_DIR)/usr/lib/libnet-1.0.x/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/libnet-1.0.x/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.{a,so*} $(STAGING_DIR)/usr/lib/libnet-1.0.x/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf $(STAGING_DIR)/usr/lib/libnet-1.0.x
|
||||
endef
|
||||
|
||||
define Package/libnet0/install
|
||||
install -m0755 -d $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libnet0))
|
@ -12,12 +12,12 @@ PKG_NAME:=libnet
|
||||
PKG_VERSION:=1.1.2.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/libnet
|
||||
PKG_SOURCE:=$(PKG_NAME).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.packetfactory.net/libnet/dist/
|
||||
PKG_MD5SUM:=be845c41170d72c7db524f3411b50256
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/libnet
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
@ -26,92 +26,63 @@ define Package/libnet1
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libpcap
|
||||
TITLE:=Low-level packet creation library
|
||||
DESCRIPTION:=Low-level packet creation library
|
||||
TITLE:=Low-level packet creation library (v1.1.x)
|
||||
URL:=http://www.packetfactory.net/libnet/
|
||||
endef
|
||||
|
||||
ENDIANESS:=lil
|
||||
ifeq ($(ARCH),mips)
|
||||
ENDIANESS:=big
|
||||
ENDIANESS:=big
|
||||
endif
|
||||
ifeq ($(ARCH),armeb)
|
||||
ENDIANESS:=big
|
||||
ENDIANESS:=big
|
||||
endif
|
||||
ifeq ($(ARCH),powerpc)
|
||||
ENDIANESS:=big
|
||||
ENDIANESS:=big
|
||||
endif
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
|
||||
touch configure.in; \
|
||||
touch include.m4; \
|
||||
touch aclocal.m4; \
|
||||
touch Makefile.in; \
|
||||
touch configure; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
(cd $(PKG_BUILD_DIR); touch \
|
||||
configure.in \
|
||||
include.m4 \
|
||||
aclocal.m4 \
|
||||
Makefile.in \
|
||||
configure \
|
||||
);
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--with-pf_packet=yes \
|
||||
, \
|
||||
ac_libnet_have_pf_packet=yes \
|
||||
ac_cv_lbl_unaligned_fail=no \
|
||||
ac_cv_libnet_endianess=$(ENDIANESS) \
|
||||
ac_libnet_have_packet_socket=yes \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--with-pf_packet=yes \
|
||||
);
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/libnet-1.1.x/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/libnet-config $(STAGING_DIR)/usr/lib/libnet-1.1.x/bin/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/libnet-1.1.x/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libnet* $(STAGING_DIR)/usr/lib/libnet-1.1.x/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib/libnet-1.1.x/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.{a,so*} $(STAGING_DIR)/usr/lib/libnet-1.1.x/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf $(STAGING_DIR)/usr/lib/libnet-1.1.x
|
||||
endef
|
||||
|
||||
define Package/libnet1/install
|
||||
install -m0755 -d $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/libnet-config $(STAGING_DIR)/usr/bin/
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libnet* $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/bin/libnet-config \
|
||||
$(STAGING_DIR)/usr/include/libnet* \
|
||||
$(STAGING_DIR)/usr/lib/libnet.{a,so*}
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libnet1))
|
@ -1,110 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libnet
|
||||
PKG_VERSION:=1.0.2a
|
||||
PKG_RELEASE:=7
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/Libnet-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.packetfactory.net/libnet/dist/deprecated/
|
||||
PKG_MD5SUM:=ddf53f0f484184390e8c2a1bd0853667
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libnet
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libpcap
|
||||
TITLE:=Low-level packet creation library
|
||||
DESCRIPTION:=Low-level packet creation library
|
||||
URL:=http://www.packetfactory.net/libnet/
|
||||
endef
|
||||
|
||||
ENDIANESS:=lil
|
||||
ifeq ($(ARCH),mips)
|
||||
ENDIANESS:=big
|
||||
endif
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
|
||||
touch configure.in; \
|
||||
touch include.m4; \
|
||||
touch aclocal.m4; \
|
||||
touch Makefile.in; \
|
||||
touch configure; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
ac_libnet_have_pf_packet=yes \
|
||||
ac_cv_lbl_unaligned_fail=no \
|
||||
ac_cv_libnet_endianess=$(ENDIANESS) \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--with-pf_packet=yes \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/libnet/install
|
||||
install -m0755 -d $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/libnet-config $(STAGING_DIR)/usr/bin/
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/libnet* $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnet.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/bin/libnet-config \
|
||||
$(STAGING_DIR)/usr/include/libnet* \
|
||||
$(STAGING_DIR)/usr/lib/libnet.{a,so*}
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libnet))
|
@ -20,67 +20,38 @@ PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
PKG_BUILDDEP:=libnet
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libnids
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libnet0
|
||||
TITLE:=A network intrusion detection library
|
||||
DESCRIPTION:=A network intrusion detection library.\\\
|
||||
An implementation of an E-component of Network Intrusion Detection \\\
|
||||
System.
|
||||
DESCRIPTION:=\
|
||||
An implementation of an E-component of Network Intrusion Detection \\\
|
||||
System.
|
||||
URL:=http://www.packetfactory.net/projects/libnids/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(call Build/Configure/Default, \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--with-libnet="$(STAGING_DIR)/usr" \
|
||||
--with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
|
||||
--with-libpcap="$(STAGING_DIR)/usr" \
|
||||
);
|
||||
, \
|
||||
CFLAGS="$$$$CFLAGS $$$$CPPFLAGS" \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
LNETLIB="-L$(STAGING_DIR)/usr/lib/libnet-1.0.x/lib -lnet" \
|
||||
PCAPLIB="-L$(STAGING_DIR)/usr/lib -lpcap" \
|
||||
install_prefix="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/libnids/install
|
||||
install -m0755 -d $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnids.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/nids.h $(STAGING_DIR)/usr/include/
|
||||
@ -89,9 +60,13 @@ define Build/InstallDev
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/include/nids.h \
|
||||
rm -rf $(STAGING_DIR)/usr/include/nids.h \
|
||||
$(STAGING_DIR)/usr/lib/libnids.{a,so*}
|
||||
endef
|
||||
|
||||
define Package/libnids/install
|
||||
install -m0755 -d $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libnids.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libnids))
|
||||
|
@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=dsniff
|
||||
PKG_VERSION:=2.4b1
|
||||
PKG_RELEASE:=2
|
||||
PKG_MD5SUM:=2f761fa3475682a7512b0b43568ee7d6
|
||||
|
||||
PKG_SOURCE_URL:=http://www.monkey.org/~dugsong/dsniff/beta
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.monkey.org/~dugsong/dsniff/beta
|
||||
PKG_MD5SUM:=2f761fa3475682a7512b0b43568ee7d6
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-2.4
|
||||
@ -25,26 +25,26 @@ include $(INCLUDE_DIR)/package.mk
|
||||
define Package/dsniff
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpcap +libnids +libnet +libopenssl +libgdbm
|
||||
DEPENDS:=+libpcap +libnids +libnet0 +libopenssl +libgdbm
|
||||
TITLE:=A collection of tools for betwork auditing and penetration testing
|
||||
DESCRIPTION:=A collection of tools for betwork auditing and penetration testing
|
||||
DESCRIPTION:=\
|
||||
A collection of tools for betwork auditing and penetration testing.
|
||||
URL:=http://www.monkey.org/~dugsong/dsniff/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,--without-db \
|
||||
--without-x \
|
||||
--with-gdbm="$(STAGING_DIR)/usr" \
|
||||
--with-libnids="$(STAGING_DIR)/usr" \
|
||||
--with-libpcap="$(STAGING_DIR)/usr" \
|
||||
--with-libnet="$(STAGING_DIR)/usr" \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
)
|
||||
$(call Build/Configure/Default, \
|
||||
--with-gdbm="$(STAGING_DIR)/usr" \
|
||||
--with-libnids="$(STAGING_DIR)/usr" \
|
||||
--with-libpcap="$(STAGING_DIR)/usr" \
|
||||
--with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--without-db \
|
||||
--without-x \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
install_prefix="$(PKG_INSTALL_DIR)" \
|
||||
@ -52,10 +52,10 @@ define Build/Compile
|
||||
endef
|
||||
|
||||
define Package/dsniff/install
|
||||
install -d -m0755 $(1)/usr/lib
|
||||
install -d -m0755 $(1)/usr/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
|
||||
install -d -m0755 $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,dsniff))
|
||||
|
@ -10,10 +10,10 @@ include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=ettercap
|
||||
PKG_VERSION:=NG-0.7.3
|
||||
PKG_RELEASE:=0
|
||||
PKG_MD5SUM:=28fb15cd024162c55249888fe1b97820
|
||||
|
||||
PKG_SOURCE_URL:=@SF/ettercap
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/ettercap
|
||||
PKG_MD5SUM:=28fb15cd024162c55249888fe1b97820
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
@ -26,34 +26,47 @@ define Package/ettercap
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpcap +libnet1 +libopenssl +libpcre +libiconv +libncurses
|
||||
TITLE:=Ettercap is a suite for man in the middle attacks on LAN.
|
||||
DESCRIPTION:=Ettercap is a suite for man in the middle attacks on LAN. It features sniffing of live connections,\\\
|
||||
content filtering on the fly and many other interesting tricks.\\\
|
||||
It supports active and passive dissection of many protocols (even ciphered ones) and includes many feature for network\\\
|
||||
and host analysis.\\\
|
||||
DESCRIPTION:=\
|
||||
It features sniffing of live connections, content filtering on the fly \\\
|
||||
and many other interesting tricks.\\\
|
||||
It supports active and passive dissection of many protocols (even \\\
|
||||
ciphered ones) and includes many feature for network and host analysis.\\\
|
||||
URL:=http://ettercap.sourceforge.net
|
||||
endef
|
||||
|
||||
define Package/ettercap/conffiles
|
||||
/etc/etter.conf
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,--with-libpcap="$(STAGING_DIR)/usr" \
|
||||
--with-libnet="$(STAGING_DIR)/usr" \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--with-libpcre="$(STAGING_DIR)/usr" \
|
||||
--with-libiconv="$(STAGING_DIR)/usr" \
|
||||
--with-libncurses="$(STAGING_DIR)/usr" \
|
||||
--disable-gtk \
|
||||
--disable-debug \
|
||||
)
|
||||
$(call Build/Configure/Default, \
|
||||
--with-libpcap="$(STAGING_DIR)/usr" \
|
||||
--with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.1.x" \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--with-libpcre="$(STAGING_DIR)/usr" \
|
||||
--with-libiconv="$(STAGING_DIR)/usr" \
|
||||
--with-libncurses="$(STAGING_DIR)/usr" \
|
||||
--disable-gtk \
|
||||
--disable-debug \
|
||||
)
|
||||
endef
|
||||
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default,DESTDIR="$(PKG_INSTALL_DIR)" all install)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/ettercap/install
|
||||
install -d -m0755 $(1)/usr/
|
||||
$(CP) $(PKG_INSTALL_DIR)/* $(1)/
|
||||
rm -rf $(1)/usr/man
|
||||
install -d -m0755 $(1)/etc
|
||||
$(CP) $(PKG_INSTALL_DIR)/etc/etter.conf $(1)/etc/
|
||||
install -d -m0755 $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/etter{cap,filter,log} $(1)/usr/bin/
|
||||
install -d -m0755 $(1)/usr/lib/ettercap
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ettercap/*.so $(1)/usr/lib/ettercap/
|
||||
install -d -m0755 $(1)/usr/share/ettercap
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/share/ettercap/* $(1)/usr/share/ettercap/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,ettercap))
|
||||
|
24
net/ettercap/patches/02-libnet_check_honor_ldflags.patch
Normal file
24
net/ettercap/patches/02-libnet_check_honor_ldflags.patch
Normal file
@ -0,0 +1,24 @@
|
||||
diff -ruN ettercap-NG-0.7.3-old/configure ettercap-NG-0.7.3-new/configure
|
||||
--- ettercap-NG-0.7.3-old/configure 2006-10-03 18:24:09.000000000 +0200
|
||||
+++ ettercap-NG-0.7.3-new/configure 2006-10-03 18:28:57.000000000 +0200
|
||||
@@ -31759,7 +31759,7 @@
|
||||
|
||||
OLDLDFLAGS="${LDFLAGS}"
|
||||
OLDLIBS="${LIBS}"
|
||||
- LDFLAGS="$LNETLIB"
|
||||
+ LDFLAGS="$LDFLAGS $LNETLIB"
|
||||
LIBS="$LIBS"
|
||||
|
||||
echo "$as_me:$LINENO: checking for libnet_adv_free_packet in -lnet" >&5
|
||||
diff -ruN ettercap-NG-0.7.3-old/configure.in ettercap-NG-0.7.3-new/configure.in
|
||||
--- ettercap-NG-0.7.3-old/configure.in 2006-10-03 18:24:09.000000000 +0200
|
||||
+++ ettercap-NG-0.7.3-new/configure.in 2006-10-03 18:26:45.000000000 +0200
|
||||
@@ -500,7 +500,7 @@
|
||||
]
|
||||
)
|
||||
|
||||
-EC_CHECK_FUNC(net, libnet_adv_free_packet, $LNETLIB, $LIBS,, AC_MSG_ERROR([Incorrect libnet version. libnet >= 1.1.2.1 required]))
|
||||
+EC_CHECK_FUNC(net, libnet_adv_free_packet, $LDFLAGS $LNETLIB, $LIBS,, AC_MSG_ERROR([Incorrect libnet version. libnet >= 1.1.2.1 required]))
|
||||
|
||||
dnl ------------------
|
||||
dnl Checks for openssl
|
@ -11,71 +11,44 @@ include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=rarpd
|
||||
PKG_VERSION:=1.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=04e2ca849e758d0b88c8281775ec3b58
|
||||
|
||||
PKG_SOURCE_URL:=ftp://ftp.dementia.org/pub/net-tools
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.dementia.org/pub/net-tools
|
||||
PKG_MD5SUM:=04e2ca849e758d0b88c8281775ec3b58
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
# Hack Alert!
|
||||
# The configure script for rarpd, when used with the --with-libnet option
|
||||
# doesn't correctly detect and set -DNEW_LIBNET_INTERFACE.
|
||||
EXTRA_CFLAGS = -DNEW_LIBNET_INTERFACE
|
||||
PKG_INIT_PRIO:=50
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/rarpd
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libnet
|
||||
DEPENDS:=+libnet0
|
||||
TITLE:=Reverse ARP Daemon
|
||||
DESCRIPTION:=Rarpd is a daemon which responds to RARP requests.\\\
|
||||
DESCRIPTION:=\
|
||||
Rarpd is a daemon which responds to RARP requests.\\\
|
||||
RARP is used by some machines at boot time to discover their\\\
|
||||
IP address. They provide their Ethernet address and rarpd\\\
|
||||
responds with their IP address if it finds it in the ethers\\\
|
||||
database.\\\
|
||||
database.
|
||||
URL:=ftp://ftp.dementia.org/pub/net-tools/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS) $(EXTRA_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-I$(STAGING_DIR)/usr/lib -I$(STAGING_DIR)/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--with-libnet="$(STAGING_DIR)/usr" \
|
||||
--with-pcap="$(STAGING_DIR)/usr" \
|
||||
);
|
||||
$(call Build/Configure/Default, \
|
||||
--with-libnet="$(STAGING_DIR)/usr/lib/libnet-1.0.x" \
|
||||
--with-pcap="$(STAGING_DIR)/usr" \
|
||||
, \
|
||||
CFLAGS="$$$$CFLAGS -DNEW_LIBNET_INTERFACE" \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
@ -87,7 +60,7 @@ define Package/rarpd/install
|
||||
install -m644 ./files/rarpd.default $(1)/etc/default/rarpd
|
||||
install -d -m0755 $(1)/etc/init.d
|
||||
install -m755 ./files/rarpd.init $(1)/etc/init.d/rarpd
|
||||
ln -sf rarpd $(1)/etc/init.d/S50rarpd
|
||||
ln -sf rarpd $(1)/etc/init.d/S$(PKG_INIT_PRIO)rarpd
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,rarpd))
|
||||
|
@ -11,28 +11,31 @@ include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=scanlogd
|
||||
PKG_VERSION:=2.2.6
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=7b8187ea718ebe47f22805b921b909ab
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.openwall.com/scanlogd/ \
|
||||
ftp://ftp.wiretapped.net/pub/openwall/ \
|
||||
http://distro.ibiblio.org/pub/linux/distributions/openwall/
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MD5SUM:=7b8187ea718ebe47f22805b921b909ab
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
PKG_INIT_PRIO:=60
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/scanlogd
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpcap +libnet +libnids
|
||||
TITLE:=a port scan detection tool
|
||||
DESCRIPTION:=Scanlogd is a TCP port scan detection tool, originally designed\\\
|
||||
DEPENDS:=+libpcap +libnet0 +libnids
|
||||
TITLE:=Port scan detection tool
|
||||
DESCRIPTION:=\
|
||||
Scanlogd is a TCP port scan detection tool, originally designed \\\
|
||||
to illustrate various attacks an IDS developer has to deal with.\\\
|
||||
Thus, unlike some of the other port scan detection tools out there,\\\
|
||||
scanlogd is designed to be totally safe to use.\\\
|
||||
Thus, unlike some of the other port scan detection tools out there, \\\
|
||||
scanlogd is designed to be totally safe to use.
|
||||
URL:=http://www.openwall.com/scanlogd
|
||||
endef
|
||||
|
||||
@ -47,16 +50,17 @@ define Build/Compile
|
||||
CC="$(TARGET_CC)" LD="$(TARGET_CC)" CFLAGS="-c $(TARGET_CFLAGS)" \
|
||||
LDFLAGS= \
|
||||
PCAP_H="-I$(STAGING_DIR)/usr/include" \
|
||||
NIDS_H="-I$(STAGING_DIR)/usr/include" \
|
||||
NIDS_L="-L$(STAGING_DIR)/usr/lib -lnids -lnet -lpcap" \
|
||||
NIDS_H="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/usr/lib/libnet-1.0.x/include" \
|
||||
NIDS_L="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/libnet-1.0.x/lib -lnids -lnet -lpcap" \
|
||||
libnids
|
||||
endef
|
||||
|
||||
define Package/scanlogd/install
|
||||
install -d -m0755 $(1)/etc/init.d
|
||||
install -m0755 ./files/scanlogd.init $(1)/etc/init.d/S60scanlogd
|
||||
install -d -m0755 $(1)/usr/sbin
|
||||
install -m0755 $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
|
||||
install -d -m0755 $(1)/etc/init.d
|
||||
install -m0755 ./files/scanlogd.init $(1)/etc/init.d/scanlogd
|
||||
ln -sf scanlogd $(1)/etc/init.d/S$(PKG_INIT_PRIO)scanlogd
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,scanlogd))
|
||||
|
@ -11,10 +11,10 @@ include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=scdp
|
||||
PKG_VERSION:=1.0b
|
||||
PKG_RELEASE:=1
|
||||
PKG_MD5SUM:=7eafaf5a422e37d04715613993ed5d95
|
||||
|
||||
PKG_SOURCE_URL:=@SF/scdp
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/scdp
|
||||
PKG_MD5SUM:=7eafaf5a422e37d04715613993ed5d95
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
@ -25,21 +25,24 @@ include $(INCLUDE_DIR)/package.mk
|
||||
define Package/scdp
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libnet
|
||||
DEPENDS:=+libnet0
|
||||
TITLE:=An utility to send CDP (Cisco Discovery Protocol) packets
|
||||
DESCRIPTION:=This program sends CDP (Cisco Discovery Protocol) packets out on\\\
|
||||
DESCRIPTION:=\
|
||||
This program sends CDP (Cisco Discovery Protocol) packets out on\\\
|
||||
selected interfaces and tells the connected switch (cisco only)\\\
|
||||
where the host is connected.\\\
|
||||
where the host is connected.
|
||||
URL:=http://sourceforge.net/projects/scdp
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default,--enable-shared)
|
||||
$(call Build/Configure/Default, \
|
||||
, \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/lib/libnet-1.0.x/include" \
|
||||
LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libnet-1.0.x/lib" \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)/
|
||||
mkdir -p $(PKG_INSTALL_DIR)/
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR=$(PKG_INSTALL_DIR) \
|
||||
all install
|
||||
|
Loading…
x
Reference in New Issue
Block a user