[packages] lvm2: update to 2.02.105

Signed-off-by: Luka Perkov <luka@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@40012 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
luka 2014-03-24 00:23:33 +00:00
parent 44ff5d201b
commit 1d5920e8b2
2 changed files with 12 additions and 12 deletions

View File

@ -1,6 +1,6 @@
#
# Copyright (C) 2009-2010 Stefan Monnier
# Copyright (C) 2011-2012 OpenWrt.org
# Copyright (C) 2011-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v3+.
# See /LICENSE for more information.
@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=LVM2
PKG_VERSION:=2.02.97
PKG_VERSION:=2.02.105
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=ftp://sources.redhat.com/pub/lvm2
PKG_MD5SUM:=d18bd01334309db1c422b9bf6b181057
PKG_MD5SUM:=b5b3540661fc70bf329b526c1cfbcf3a
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME).$(PKG_VERSION)
include $(INCLUDE_DIR)/package.mk
@ -24,7 +24,7 @@ define Package/libdevmapper
CATEGORY:=Libraries
TITLE:=The Linux Kernel Device Mapper userspace library
URL:=http://sourceware.org/dm/
DEPENDS:=+kmod-dm
DEPENDS:=+kmod-dm +libpthread
endef
define Package/libdevmapper/description
@ -38,7 +38,7 @@ define Package/lvm2
SUBMENU:=disc
TITLE:=The Linux Logical Volume Manager
URL:=http://sourceware.org/lvm2/
DEPENDS:=+libdevmapper +libreadline +libncurses
DEPENDS:=+libdevmapper +libblkid +libreadline +libncurses
endef
define Package/lvm2/description
@ -74,7 +74,7 @@ define Package/lvm2/install
$(INSTALL_DIR) $(1)/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tools/lvm $(1)/sbin
$(INSTALL_DIR) $(1)/etc/lvm
$(INSTALL_CONF) $(PKG_BUILD_DIR)/doc/example.conf $(1)/etc/lvm/lvm.conf
$(INSTALL_CONF) $(PKG_BUILD_DIR)/conf/example.conf $(1)/etc/lvm/lvm.conf
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/lvm2.init $(1)/etc/init.d/lvm2
endef

View File

@ -1,11 +1,11 @@
--- a/make.tmpl.in
+++ b/make.tmpl.in
@@ -17,7 +17,7 @@ SHELL = /bin/sh
@SET_MAKE@
@@ -19,7 +19,7 @@
# Allow environment to override any built-in default value for CC.
# If there is a built-in default, CC is NOT set to @CC@ here.
-CC ?= @CC@
+CC = @CC@
RANLIB = @RANLIB@
INSTALL = @INSTALL@
MKDIR_P = @MKDIR_P@
# If $(CC) holds the usual built-in default value of 'cc' then replace it with
# the configured value.