Port BitchX to -ng, fix compilation by adding correct CFLAGS

git-svn-id: svn://svn.openwrt.org/openwrt/packages@4349 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-07-31 13:28:31 +00:00
parent c07d89fdc8
commit 1e17a97ad0
5 changed files with 122 additions and 0 deletions

79
net/bitchx/Makefile Normal file
View File

@ -0,0 +1,79 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=bitchx
PKG_VERSION:=1.1
PKG_RELEASE:=1
PKG_MD5SUM:=611d2dda222f00c10140236f4c331572
PKG_SOURCE_URL:=http://bitchx.org/files/source/
PKG_SOURCE:=ircii-pana-$(PKG_VERSION)-final.tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/BitchX
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_BUILDDEP:=libncurses
include $(INCLUDE_DIR)/package.mk
define Package/bitchx
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libncurses
TITLE:=popular IRC client
DESCRIPTION:=popular IRC client
URL:=http://www.bitchx.org
endef
define Build/Configure
$(call Build/Configure/Default)
endef
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
DESTDIR="$(PKG_INSTALL_DIR)" \
all
mkdir -p $(PKG_INSTALL_DIR)/tmp
mkdir -p $(PKG_INSTALL_DIR)/etc/init.d
mkdir -p $(PKG_INSTALL_DIR)/usr/bin
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx
mkdir -p $(PKG_INSTALL_DIR)/usr/share/man/man1
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/translation
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/plugins
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/bx/help
install -c $(PKG_BUILD_DIR)/source/BitchX $(PKG_INSTALL_DIR)/usr/bin/BitchX-1.1-final
rm -f $(PKG_INSTALL_DIR)/usr/bin/BitchX
ln -s /usr/bin/BitchX-1.1-final $(PKG_INSTALL_DIR)/usr/bin/BitchX
install -c $(PKG_BUILD_DIR)/BitchX.help $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.help
install -c $(PKG_BUILD_DIR)/BitchX.ircnames $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.ircnames
install -c $(PKG_BUILD_DIR)/BitchX.quit $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.quit
install -c $(PKG_BUILD_DIR)/BitchX.reasons $(PKG_INSTALL_DIR)/usr/lib/bx/BitchX.kick
install -c $(PKG_BUILD_DIR)/source/wserv $(PKG_INSTALL_DIR)/usr/lib/bx/wserv
install -c $(PKG_BUILD_DIR)/source/scr-bx $(PKG_INSTALL_DIR)/usr/bin/scr-bx
$(CP) $(PKG_BUILD_DIR)/script $(PKG_INSTALL_DIR)/usr/lib/bx/
$(CP) $(PKG_BUILD_DIR)/translation $(PKG_INSTALL_DIR)/usr/lib/bx/
bzip2 $(PKG_INSTALL_DIR)/usr/lib/bx/translation/*
$(CP) ./files/bitchxrc $(PKG_INSTALL_DIR)/tmp/.bitchxrc
$(CP) ./files/S98bitchxrc $(PKG_INSTALL_DIR)/etc/init.d/S98bitchxrc
endef
define Package/bitchx/install
install -m0755 -d $(1)/usr/bin $(1)/usr/lib $(1)/etc/init.d $(1)/tmp
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/etc/init.d/S98bitchxrc $(1)/etc/init.d/
$(CP) $(PKG_INSTALL_DIR)/tmp/.bitchxrc $(1)/tmp
endef
$(eval $(call BuildPackage,bitchx))

7
net/bitchx/files/S98bitchxrc Executable file
View File

@ -0,0 +1,7 @@
#!/bin/sh
# make /tmp/.bitchxrc as many servers ban root
if [ ! -e /tmp/.bitchxrc ]
then
echo "IRCUSER OpenWrt" >/tmp/.bitchxrc
echo "IRCNAME OpenWrt User!" >>/tmp/.bitchxrc
fi

View File

@ -0,0 +1,2 @@
IRCUSER OpenWrt
IRCNAME OpenWrt User!

View File

@ -0,0 +1,24 @@
diff -urN BitchX/include/ctcp.h BitchX.new/include/ctcp.h
--- BitchX/include/ctcp.h 2003-04-11 03:09:07.000000000 +0200
+++ BitchX.new/include/ctcp.h 2006-03-29 13:19:21.170693168 +0200
@@ -56,7 +56,7 @@
extern CtcpEntryDll *dll_ctcp;
-extern char *ctcp_type[];
+//extern char *ctcp_type[]; /* already declared in ctcp.c
extern int sed;
extern int in_ctcp_flag;
diff -urN BitchX/include/struct.h BitchX.new/include/struct.h
--- BitchX/include/struct.h 2003-04-11 03:09:07.000000000 +0200
+++ BitchX.new/include/struct.h 2006-03-29 13:19:26.653859600 +0200
@@ -1064,7 +1064,7 @@
int delete;
} TimerList;
-extern TimerList *PendingTimers;
+//extern TimerList *PendingTimers;
typedef struct nicktab_stru
{
struct nicktab_stru *next;

View File

@ -0,0 +1,10 @@
--- BitchX/source/term.c.orig 2006-03-05 15:01:46.000000000 +1000
+++ BitchX/source/term.c 2006-03-05 15:01:53.000000000 +1000
@@ -92,7 +92,6 @@
#endif
extern char *getenv();
-extern char *tparm();
/*
* The old code assumed termcap. termcap is almost always present, but on