Add libnmeap (#1999)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8155 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2007-07-25 13:51:45 +00:00
parent 472d3ee8eb
commit 1ef76bdc70
2 changed files with 65 additions and 0 deletions

44
libs/nmeap/Makefile Normal file
View File

@ -0,0 +1,44 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id: $
include $(TOPDIR)/rules.mk
PKG_NAME:=nmeap
PKG_VERSION:=0.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/nmeap
PKG_MD5SUM:=cbcc9fdf5176f9d6c9e48f27db443c4f
include $(INCLUDE_DIR)/package.mk
define Package/libnmeap
SECTION:=libs
CATEGORY:=Libraries
TITLE:=extensible NMEA-0183 parser written in standard C
DESCRIPTION:=The NMEAP parser is intended for use in applications that need to input NMEA-0183 \\\
data from a GPS (typically over a serial port). NMEAP is a linkable library written in portable \\\
standard C and is suitable for both desktop and embedded applications. \\\
It is licensed under the BSD open source license.
URL:=http://www.dmh2000.com/nmea/nmeap.shtml
endef
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR)/usr/include
$(CP) $(PKG_BUILD_DIR)/inc/nmeap{,_def}.h $(STAGING_DIR)/usr/include/
$(INSTALL_DIR) $(STAGING_DIR)/usr/lib
$(CP) $(PKG_BUILD_DIR)/lib/libnmeap.a $(STAGING_DIR)/usr/lib/
endef
define Build/UninstallDev
rm -f $(STAGING_DIR)/usr/include/nmeap{,_def}.h \
$(STAGING_DIR)/usr/lib/libnmeap.a
endef
$(eval $(call BuildPackage,libnmeap))

View File

@ -0,0 +1,21 @@
--- nmeap-0.3/Makefile 2005-05-06 19:57:39.000000000 +0200
+++ nmeap-0.3.new/Makefile 2007-07-25 15:26:47.000000000 +0200
@@ -5,18 +5,15 @@
# directories
BASE :=$(shell pwd)
export SRC=$(BASE)/src
-export TST=$(BASE)/tst
export INC=$(BASE)/inc
export LIB=$(BASE)/lib
all :
cd $(SRC) && $(MAKE) all
- cd $(TST) && $(MAKE) all
clean :
cd $(SRC) && $(MAKE) clean
- cd $(TST) && $(MAKE) clean
doc :
doxygen