[package] update fftw3 to 3.2.1 (#5391)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16530 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6b946d0933
commit
1f3a465437
@ -1,18 +1,19 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2007 OpenWrt.org
|
# Copyright (C) 2007 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=fftw3
|
PKG_NAME:=fftw3
|
||||||
PKG_VERSION:=3.1.2
|
PKG_VERSION:=3.2.1
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE:=fftw-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.fftw.org/
|
PKG_SOURCE_URL:=http://www.fftw.org
|
||||||
PKG_SOURCE:=fftw-3.1.2.tar.gz
|
PKG_MD5SUM:=712d3f33625a0a76f5758648d4b925f7
|
||||||
PKG_MD5SUM:=08f2e21c9fd02f4be2bd53a62592afa4
|
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/fftw-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/fftw-$(PKG_VERSION)
|
||||||
|
|
||||||
@ -31,7 +32,6 @@ define Package/fftw3/description
|
|||||||
Discrete Fourier Transform in one or more dimensions. It
|
Discrete Fourier Transform in one or more dimensions. It
|
||||||
includes complex, real, and parallel transforms, and can
|
includes complex, real, and parallel transforms, and can
|
||||||
handle arbitrary array sizes efficiently.
|
handle arbitrary array sizes efficiently.
|
||||||
http://www.fftw.org/
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
TARGET_CFLAGS += $(FPIC)
|
||||||
|
@ -1,21 +1,20 @@
|
|||||||
diff -Naur fftw-3.1.2/Makefile.in fftw-3.1.2-p/Makefile.in
|
--- a/Makefile.in
|
||||||
--- fftw-3.1.2/Makefile.in 2006-01-28 01:19:57.000000000 +0100
|
+++ b/Makefile.in
|
||||||
+++ fftw-3.1.2-p/Makefile.in 2006-03-13 20:50:29.829075989 +0100
|
@@ -110,7 +110,7 @@ RECURSIVE_CLEAN_TARGETS = mostlyclean-re
|
||||||
@@ -112,7 +112,7 @@
|
|
||||||
ETAGS = etags
|
ETAGS = etags
|
||||||
CTAGS = ctags
|
CTAGS = ctags
|
||||||
DIST_SUBDIRS = support genfft genfft-k7 kernel simd dft rdft reodft \
|
DIST_SUBDIRS = support genfft kernel simd dft rdft reodft api threads \
|
||||||
- threads api libbench2 . tests doc tools
|
- cell libbench2 . tests doc tools m4
|
||||||
+ threads api libbench2 . doc tools
|
+ cell libbench2 . doc tools m4
|
||||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||||
distdir = $(PACKAGE)-$(VERSION)
|
distdir = $(PACKAGE)-$(VERSION)
|
||||||
top_distdir = $(distdir)
|
top_distdir = $(distdir)
|
||||||
@@ -277,7 +277,7 @@
|
@@ -278,7 +278,7 @@ lib_LTLIBRARIES = libfftw3@PREC_SUFFIX@.
|
||||||
@MAINTAINER_MODE_TRUE@GENFFT = genfft genfft-k7
|
@MAINTAINER_MODE_TRUE@GENFFT = genfft
|
||||||
ACLOCAL_AMFLAGS = -I ./m4
|
ACLOCAL_AMFLAGS = -I m4
|
||||||
SUBDIRS = support $(GENFFT) kernel simd dft rdft reodft threads api \
|
SUBDIRS = support $(GENFFT) kernel simd dft rdft reodft api threads \
|
||||||
-libbench2 . tests doc tools
|
-cell libbench2 . tests doc tools m4
|
||||||
+libbench2 .
|
+cell libbench2 . m4
|
||||||
|
|
||||||
EXTRA_DIST = COPYRIGHT bootstrap.sh CONVENTIONS fftw.pc.in m4
|
EXTRA_DIST = COPYRIGHT bootstrap.sh CONVENTIONS fftw.pc.in README.Cell
|
||||||
@HAVE_SIMD_FALSE@SIMD_LIBS =
|
@HAVE_SIMD_TRUE@SIMD_LIBS = \
|
||||||
|
Loading…
x
Reference in New Issue
Block a user