[packages] ipsec-tools: update to v0.7.2
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16011 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
feadc1a528
commit
23a3c3ed1d
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
# Copyright (C) 2006-2009 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=ipsec-tools
|
||||
PKG_VERSION:=0.7
|
||||
PKG_VERSION:=0.7.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/ipsec-tools
|
||||
PKG_MD5SUM:=c0a586924edde35264ecfe94ad1c261f
|
||||
PKG_MD5SUM:=72861f005746ee27984b2ee715ecc629
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: ipsec-tools-0.6.6/src/racoon/cftoken.l
|
||||
===================================================================
|
||||
--- ipsec-tools-0.6.6.orig/src/racoon/cftoken.l 2007-06-04 13:22:36.567296208 +0200
|
||||
+++ ipsec-tools-0.6.6/src/racoon/cftoken.l 2007-06-04 13:22:36.646284200 +0200
|
||||
@@ -105,6 +105,8 @@
|
||||
--- a/src/racoon/cftoken.l
|
||||
+++ b/src/racoon/cftoken.l
|
||||
@@ -104,6 +104,8 @@ static struct include_stack {
|
||||
static int incstackp = 0;
|
||||
|
||||
static int yy_first_time = 1;
|
||||
@ -11,13 +9,11 @@ Index: ipsec-tools-0.6.6/src/racoon/cftoken.l
|
||||
%}
|
||||
|
||||
/* common seciton */
|
||||
Index: ipsec-tools-0.6.6/src/setkey/token.l
|
||||
===================================================================
|
||||
--- ipsec-tools-0.6.6.orig/src/setkey/token.l 2007-06-04 13:22:36.575294992 +0200
|
||||
+++ ipsec-tools-0.6.6/src/setkey/token.l 2007-06-04 13:22:36.646284200 +0200
|
||||
@@ -84,6 +84,8 @@
|
||||
#ifndef SADB_X_EALG_AESCTR
|
||||
#define SADB_X_EALG_AESCTR (-1)
|
||||
--- a/src/setkey/token.l
|
||||
+++ b/src/setkey/token.l
|
||||
@@ -86,6 +86,8 @@
|
||||
#if defined(SADB_X_EALG_AES) && ! defined(SADB_X_EALG_AESCBC)
|
||||
#define SADB_X_EALG_AESCBC SADB_X_EALG_AES
|
||||
#endif
|
||||
+
|
||||
+int yywrap(void) { return 1; }
|
||||
|
@ -1,26 +0,0 @@
|
||||
Index: ipsec-tools-0.6.6/configure.ac
|
||||
===================================================================
|
||||
--- ipsec-tools-0.6.6.orig/configure.ac 2007-06-04 13:22:36.540300312 +0200
|
||||
+++ ipsec-tools-0.6.6/configure.ac 2007-06-04 13:22:36.841254560 +0200
|
||||
@@ -183,7 +183,7 @@
|
||||
|
||||
if test "x$crypto_dir" != "x"; then
|
||||
LIBS="$LIBS -L${crypto_dir}/lib"
|
||||
- CPPFLAGS="-I${crypto_dir}/include $CPPLAGS"
|
||||
+ CPPFLAGS="-I${crypto_dir}/include $CPPFLAGS"
|
||||
fi
|
||||
AC_MSG_CHECKING(openssl version)
|
||||
|
||||
Index: ipsec-tools-0.6.6/configure
|
||||
===================================================================
|
||||
--- ipsec-tools-0.6.6.orig/configure 2007-06-04 13:22:36.547299248 +0200
|
||||
+++ ipsec-tools-0.6.6/configure 2007-06-04 13:22:36.850253192 +0200
|
||||
@@ -23687,7 +23687,7 @@
|
||||
|
||||
if test "x$crypto_dir" != "x"; then
|
||||
LIBS="$LIBS -L${crypto_dir}/lib"
|
||||
- CPPFLAGS="-I${crypto_dir}/include $CPPLAGS"
|
||||
+ CPPFLAGS="-I${crypto_dir}/include $CPPFLAGS"
|
||||
fi
|
||||
echo "$as_me:$LINENO: checking openssl version" >&5
|
||||
echo $ECHO_N "checking openssl version... $ECHO_C" >&6
|
@ -1,8 +1,6 @@
|
||||
Index: ipsec-tools-0.6.6/src/racoon/grabmyaddr.c
|
||||
===================================================================
|
||||
--- ipsec-tools-0.6.6.orig/src/racoon/grabmyaddr.c 2007-06-04 13:22:36.521303200 +0200
|
||||
+++ ipsec-tools-0.6.6/src/racoon/grabmyaddr.c 2007-06-04 13:22:37.064220664 +0200
|
||||
@@ -77,10 +77,17 @@
|
||||
--- a/src/racoon/grabmyaddr.c
|
||||
+++ b/src/racoon/grabmyaddr.c
|
||||
@@ -80,10 +80,17 @@
|
||||
#ifdef __linux__
|
||||
#include <linux/types.h>
|
||||
#include <linux/rtnetlink.h>
|
||||
|
Loading…
x
Reference in New Issue
Block a user