[package] fix urbi compilation failure on octeon (#6987)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20574 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2010-03-29 11:03:21 +00:00
parent ad2972e576
commit 245e4b77b4
2 changed files with 12 additions and 2 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2007 OpenWrt.org
# Copyright (C) 2007-2010 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=urbi
PKG_VERSION:=1.0RC2-l455
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-sdk-$(PKG_VERSION)-src.zip
PKG_SOURCE_URL:=http://www.gostai.com/downloads/aibo/

View File

@ -10,3 +10,13 @@ index bb2546d..38b0d8e 100644
namespace libport
{
--- a/src/liburbi/uconversion.cc 2007-01-31 11:37:04.000000000 +0100
+++ b/src/liburbi/uconversion.cc 2010-03-29 09:43:00.000000000 +0200
@@ -1,5 +1,7 @@
#include "urbi/uconversion.hh"
+#include <cstdio>
+
#ifndef NO_IMAGE_CONVERSION
# include <setjmp.h>