fix uClibc++ issue after build dir reorg: install uClibc++ headers in a separate include dir

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8598 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2007-09-03 15:58:55 +00:00
parent 50d1b76d54
commit 25e391427b
15 changed files with 306 additions and 284 deletions

View File

@ -4,7 +4,7 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id :$
# $Id$
include $(TOPDIR)/rules.mk
@ -15,61 +15,52 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://developer.kde.org/~wheeler/files/src/
PKG_MD5SUM:=dcd50ddb2544faeae77f194804559404
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/taglib
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+zlib +uclibcxx
DEPENDS:= +uclibcxx +zlib
TITLE:=Audio output library
DESCRIPTION:=\
the audio output library
URL:=http://developer.kde.org/~wheeler/taglib.html
endef
CONFIGURE_VARS += \
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++ -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include"
CONFIGURE_ARGS += \
--enable-shared \
--enable-static \
--enable-final \
define Build/Configure
$(call Build/Configure/Default, \
--enable-final \
,\
LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
LIBS="-luClibc++ -lc -lm -lgcc -lz" \
)
endef
CONFIGURE_VARS += \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LDFLAGS="$$$$LDFLAGS" \
LIBS="-nodefaultlibs -lz -luClibc++" \
define Build/Compile
$(call Build/Compile/Default,\
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install \
)
all install
endef
define Build/InstallDev
mkdir -p $(STAGING_DIR)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(STAGING_DIR)/usr/bin/
$(CP) $(PKG_INSTALL_DIR)/usr/bin/taglib-config $(STAGING_DIR)/usr/bin/
mkdir -p $(STAGING_DIR)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtag* $(STAGING_DIR)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtag.{a,so*} $(STAGING_DIR)/usr/lib/
mkdir -p $(STAGING_DIR)/usr/include/taglib
$(CP) $(PKG_INSTALL_DIR)/usr/include/taglib/* $(STAGING_DIR)/usr/include/taglib/
endef
define Build/UninstallDev
rm -rf \
$(STAGING_DIR)/usr/bin/taglib-config \
$(STAGING_DIR)/usr/lib/libtag* \
$(STAGING_DIR)/usr/include/taglib/
rm -rf $(STAGING_DIR)/usr/bin/taglib-config \
$(STAGING_DIR)/usr/include/taglib \
$(STAGING_DIR)/usr/lib/libtag.{a,so*}
endef
define Package/taglib/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtag* $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libtag.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,taglib))

View File

@ -42,6 +42,13 @@ UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
-e 's/cris.*/cris/' \
)
MAKE_FLAGS:= \
TOPDIR="$(PKG_BUILD_DIR)/" \
$(TARGET_CONFIGURE_OPTS) \
ARCH_CFLAGS="$(TARGET_CFLAGS)" \
CROSS="$(TARGET_CROSS)" \
CP="$(CP)" \
define Build/Configure
if [ -f ./files/config.$(UCLIBC_TARGET_ARCH) ]; then \
cp ./files/config.$(UCLIBC_TARGET_ARCH) $(PKG_BUILD_DIR)/.config; \
@ -51,34 +58,45 @@ define Build/Configure
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
TOPDIR="$(PKG_BUILD_DIR)/" \
$(TARGET_CONFIGURE_OPTS) \
ARCH_CFLAGS="$(TARGET_CFLAGS)" \
CROSS="$(TARGET_CROSS)" \
CP="$(CP)" \
# fix ccache issue
$(MAKE) -C $(PKG_BUILD_DIR)/src/abi/libsupc \
$(MAKE_FLAGS) \
CC="$(TARGET_CROSS)gcc" \
all
$(MAKE) -C $(PKG_BUILD_DIR) \
$(MAKE_FLAGS) \
DESTDIR="$(PKG_INSTALL_DIR)/usr" \
all install
endef
define Build/InstallDev
mkdir -p $(STAGING_DIR)/usr/include
$(MAKE) -C $(PKG_BUILD_DIR) \
TOPDIR="$(PKG_BUILD_DIR)/" \
$(TARGET_CONFIGURE_OPTS) \
ARCH_CFLAGS="$(TARGET_CFLAGS)" \
CROSS="$(TARGET_CROSS)" \
DESTDIR="$(STAGING_DIR)" \
install
mkdir -p $(STAGING_DIR)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/g++-uc $(STAGING_DIR)/usr/bin/
mkdir -p $(STAGING_DIR)/usr/include/uClibc++
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(STAGING_DIR)/usr/include/uClibc++/
mkdir -p $(STAGING_DIR)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libuClibc++*.{a,so*} $(STAGING_DIR)/usr/lib/
$(SED) 's,-I/include/,-I$(STAGING_DIR)/usr/include/uClibc++/,g' $(STAGING_DIR)/usr/bin/g++-uc
$(SED) 's,-L/lib/,-L$(STAGING_DIR)/usr/lib/,g' $(STAGING_DIR)/usr/bin/g++-uc
$(if $(STAGING_DIR_HOST), \
ln -sf $(shell $(SCRIPT_DIR)/abs2rel.pl $(STAGING_DIR)/usr/bin/g++-uc $(STAGING_DIR_HOST)/bin/) $(STAGING_DIR_HOST)/bin/ \
)
endef
define Build/UninstallDev
rm -rf $(STAGING_DIR)/lib/libuClibc++*.{a,so*}
rm -rf $(STAGING_DIR)/usr/bin/g++-uc \
$(STAGING_DIR)/usr/include/uClibc++ \
$(STAGING_DIR)/usr/lib/libuClibc++*.{a,so*}
$(if $(STAGING_DIR_HOST), \
rm -f $(STAGING_DIR_HOST)/bin/g++-uc \
)
endef
define Package/uclibcxx/install
$(INSTALL_DIR) $(1)/lib
$(CP) $(PKG_BUILD_DIR)/src/libuClibc++*.so.* $(1)/lib/
$(CP) $(PKG_BUILD_DIR)/src/libuClibc++-*.so $(1)/lib/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libuClibc++.so.* $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libuClibc++-*.so $(1)/usr/lib/
endef
$(eval $(call BuildPackage,uclibcxx))

View File

@ -15,10 +15,6 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.cti.ecp.fr/~beauxir5/peercast
PKG_MD5SUM:=4e8449cde7135ad97f788e67e1bd64ee
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
@ -27,11 +23,6 @@ define Package/peercast
CATEGORY:=Multimedia
DEPENDS:=+libpthread +uclibcxx
TITLE:=P2P audio and video streaming server
DESCRIPTION:=\
PeerCast is a fresh new P2P streaming server. It can stream music \\\
and video from a broad variety of formats. Many audio players can \\\
listen to peercast streams, as it's been built to remain compatible \\\
with Nullsoft Shoutcast.
URL:=http://www.peercast.org/
endef
@ -39,15 +30,21 @@ define Package/peercast/conffiles
/etc/peercast.ini
endef
define Build/Configure
$(call Build/Configure/Default, \
--enable-staticbin \
, \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -luClibc++ -lpthread -lc -lm" \
)
define Package/peercast/description
PeerCast is a fresh new P2P streaming server. It can stream music and
video from a broad variety of formats. Many audio players can listen to
peercast streams, as it's been built to remain compatible with Nullsoft
Shoutcast.
endef
CONFIGURE_ARGS += \
--enable-staticbin \
CONFIGURE_VARS += \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -luClibc++ -lpthread" \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \

View File

@ -20,39 +20,64 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
define Package/cbtt
define Package/cbtt/Default
SECTION:=net
CATEGORY:=Network
DEPENDS:=zlib
MENU:=1
DEPENDS:=+libpthread +uclibcxx +zlib
TITLE:=Bittorrent tracker
DEPENDS:=+libpthread +uclibcxx
DESCRIPTION:=a C BitTorrent Tracker
URL:=http://bnbtusermods.sourceforge.net
endef
define Package/cbtt
$(call Package/cbtt/Default)
endef
define Package/cbtt-mysql
SECTION:=net
CATEGORY:=Network
DEPENDS:=cbtt +libmysqlclient
TITLE:=Bittorrent tracker with mysql support
DESCRIPTION:=Bittorrent tracker with mysql support
URL:=http://bnbtusermods.sourceforge.net
DEPENDS+= +libmysqlclient
TITLE+= (with mysql support)
endef
MAKE_FLAGS += \
LFLAGS="-L$(STAGING_DIR)/lib -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/usr/lib/mysql -L. -lz -lmysqlclient -nodefaultlibs -lpthread -luClibc++ -lc -lm -lgcc" \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -fno-builtin -fno-rtti -nostdinc++"
define Package/cbtt/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bnbt $(1)/usr/bin/
define Build/Template
$(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
$(MAKE) -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
LFLAGS="$(TARGET_LDFLAGS) -L. -nodefaultlibs $(4) -lz -luClibc++ -lm -lpthread" \
$(3)
touch $$@
$(STAMP_BUILT): $(STAMP_BUILT)-$(2)
define Package/$(1)/install
$(INSTALL_DIR) $$(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(3) $$(1)/usr/bin/
endef
define Package/cbtt-mysql/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/bnbtmysql $(1)/usr/bin/
endef
define Build/Configure
endef
define Build/Compile
endef
ifneq ($(SDK)$(CONFIG_PACKAGE_cbtt),)
define Build/without-mysql
$(call Build/Template,cbtt,without-mysql,bnbt,)
endef
endif
$(eval $(Build/without-mysql))
ifneq ($(SDK)$(CONFIG_PACKAGE_cbtt-mysql),)
define Build/with-mysql
$(call Build/Template,cbtt-mysql,with-mysql,bnbtmysql, \
-L$(STAGING_DIR)/usr/lib/mysql -lmysqlclient \
)
endef
endif
$(eval $(Build/with-mysql))
$(eval $(call BuildPackage,cbtt))
$(eval $(call BuildPackage,cbtt-mysql))

View File

@ -23,17 +23,19 @@ define Package/ctorrent
CATEGORY:=Network
DEPENDS:=+libopenssl +uclibcxx
TITLE:=console-based BitTorrent client
DESCRIPTION:=\
CTorrent is a BitTorrent client written in the C programming language, known to \\\
be a very robust and mature programming language, which produces fast and \\\
optimized application.
URL:=http://www.rahul.net/dholmes/ctorrent/
endef
define Package/ctorrent/description
CTorrent is a BitTorrent client written in the C programming language,
known to be a very robust and mature programming language, which produces
fast and optimized application.
endef
CONFIGURE_ARGS += \
CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/openssl" \
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -lcrypto -luClibc++ -lm -lc -lgcc"
CONFIGURE_VARS += \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -lcrypto -luClibc++ -lm"
define Package/ctorrent/install
$(INSTALL_DIR) $(1)/usr/bin

View File

@ -15,10 +15,6 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://dast.nlanr.net/Projects/Iperf2.0
PKG_MD5SUM:=bb658aba58a5af0356f5b1342dfe8f53
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
@ -27,23 +23,24 @@ define Package/iperf
CATEGORY:=Network
DEPENDS:=+uclibcxx
TITLE:=Internet Protocol bandwidth measuring tool
DESCRIPTION:=\
Iperf is a modern alternative for measuring TCP and UDP bandwidth \\\
performance, allowing the tuning of various parameters and \\\
characteristics.
URL:=http://dast.nlanr.net/Projects/Iperf/
endef
define Build/Configure
$(call Build/Configure/Default, \
--disable-multicast \
--disable-threads \
, \
CXXFLAGS="$$$$CXX_CFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -luClibc++ -lc -lm -lgcc_s" \
)
define Package/iperf/description
Iperf is a modern alternative for measuring TCP and UDP bandwidth
performance, allowing the tuning of various parameters and
characteristics.
endef
CONFIGURE_ARGS += \
--disable-multicast \
--disable-threads \
CONFIGURE_VARS += \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
CXXFLAGS="$$$$CXX_CFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -luClibc++" \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \

View File

@ -12,29 +12,33 @@ PKG_NAME:=kismet
PKG_VERSION:=2007-01-R1a
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.kismetwireless.net/code
PKG_MD5SUM:=5921166366d3f695eeef26121c56a674
PKG_CAT:=zcat
PKG_BUILD_DEPENDS:=libpcap libncurses uclibcxx
PKG_BUILD_DEPENDS:=libnotimpl libpcap libncurses uclibcxx
include $(INCLUDE_DIR)/package.mk
define Package/kismet-client
define Package/kismet/Default
SECTION:=net
CATEGORY:=Network
TITLE:=Kismet client
DEPENDS:=+libncurses +uclibcxx
DESCRIPTION:=Kismet client.\\\
An 802.11 layer2 wireless network detector, sniffer, and intrusion \\\
detection system.\\\
\\\
This package contains the kismet text interface client.
TITLE:=Kismet
DEPENDS:= +uclibcxx
URL:=http://www.kismetwireless.net/
endef
define Package/kismet/Default/description
An 802.11 layer2 wireless network detector, sniffer, and intrusion
detection system.
endef
define Package/kismet-client
$(call Package/kismet/Default)
TITLE+= client
DEPENDS+= +libncurses
endef
define Package/kismet-client/conffiles
/etc/kismet/ap_manuf
/etc/kismet/client_manuf
@ -42,34 +46,30 @@ define Package/kismet-client/conffiles
/etc/kismet/kismet_ui.conf
endef
define Package/kismet-client/description
$(call Package/kismet/Default/description)
This package contains the kismet text interface client.
endef
define Package/kismet-drone
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libpcap +uclibcxx
TITLE:=Kismet drone
DESCRIPTION:=Kismet drone.\\\
An 802.11 layer2 wireless network detector, sniffer, and intrusion \\\
detection system.\\\
\\\
This package contains the kismet remote sniffing.and monitoring drone.
URL:=http://www.kismetwireless.net/
$(call Package/kismet/Default)
DEPENDS+= +libpcap
TITLE+= drone
endef
define Package/kismet-drone/conffiles
/etc/kismet/kismet_drone.conf
endef
define Package/kismet-drone/description
$(call Package/kismet/Default/description)
This package contains the kismet remote sniffing.and monitoring drone.
endef
define Package/kismet-server
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libpcap +uclibcxx
TITLE:=Kismet server
DESCRIPTION:=Kismet server.\\\
An 802.11 layer2 wireless network detector, sniffer, and intrusion \\\
detection system.\\\
\\\
This package contains the kismet server.
URL:=http://www.kismetwireless.net/
$(call Package/kismet/Default)
DEPENDS+= +libpcap
TITLE+= server
endef
define Package/kismet-server/conffiles
@ -78,44 +78,26 @@ define Package/kismet-server/conffiles
/etc/kismet/kismet.conf
endef
define Build/Configure
(cd $(PKG_BUILD_DIR); rm -rf config.cache; \
$(TARGET_CONFIGURE_OPTS) \
CFLAGS="$(TARGET_CFLAGS)" \
CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(LINUX_DIR)/include" \
LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
LIBS="-luClibc++ -lc -lm -lgcc" \
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc/kismet \
$(DISABLE_LARGEFILE) \
$(DISABLE_NLS) \
--enable-syspcap=yes \
--disable-setuid \
--disable-wsp100 \
--disable-gpsmap \
);
define Package/kismet-server/description
$(call Package/kismet/Default/description)
This package contains the kismet server.
endef
CONFIGURE_ARGS += \
--enable-syspcap=yes \
--disable-setuid \
--disable-wsp100 \
--disable-gpsmap \
CONFIGURE_VARS += \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
LDFLAGS="$$$$LDFLAGS" \
LIBS="-nodefaultlibs -luClibc++ -lm -lnotimpl" \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
LIBS="-luClibc++ -lc -lm -lgcc" \
LD="\$$$$(CC)" \
all
endef

View File

@ -11,30 +11,24 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=miredo
PKG_VERSION:=1.0.0
PKG_RELEASE:=1
PKG_MD5SUM:=b5a51cb98732decc2ada96b2caee5d3c
PKG_SOURCE_URL:=http://www.remlab.net/files/miredo/
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_MD5SUM:=b5a51cb98732decc2ada96b2caee5d3c
include $(INCLUDE_DIR)/package.mk
define Package/miredo
define Package/miredo/Default
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libpthread +uclibcxx +kmod-ipv6 +kmod-tun
SUBMENU:=miredo - Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon
DESCRIPTION:=miredo - A Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon.
SUBMENU:=miredo: Teredo (IPv6 tunneling over UDP through NAT)
URL:=http://www.simphalempin.com/dev/miredo/
endef
define Package/miredo-server
$(call Package/miredo)
$(call Package/miredo/Default)
TITLE:=Teredo (IPv6 tunneling over UDP through NAT) server daemon
DESCRIPTION:=A Teredo (IPv6 tunneling over UDP through NAT) server daemon.
endef
define Package/miredo-server/conffiles
@ -42,17 +36,16 @@ define Package/miredo-server/conffiles
endef
define Package/miredo-client
$(call Package/miredo)
$(call Package/miredo/Default)
TITLE:=Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon
DESCRIPTION:=Teredo (IPv6 tunneling over UDP through NAT) client and relay daemon
endef
define Package/miredo-client/conffiles
/etc/miredo.conf
endef
define Build/Configure
$(call Build/Configure/Default,--disable-shared \
CONFIGURE_ARGS += \
--disable-shared \
--enable-static \
--with-gnu-ld \
--disable-rpath \
@ -60,17 +53,15 @@ $(call Build/Configure/Default,--disable-shared \
--enable-teredo-client \
--enable-teredo-relay \
--enable-teredo-server \
--enable-miredo-user=root,CXXFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
LDFLAGS="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
LIBS="-luClibc++ -lc -lm" \
--enable-miredo-user=root \
CONFIGURE_VARS += \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -luClibc++ -lm" \
ac_cv_file__proc_self_maps=yes\
)
endef
define Build/Compile
rm -rf $(PKG_INSTALL_DIR)
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
CXXLINK="\$$$$(LINK)" \
DESTDIR="$(PKG_INSTALL_DIR)" \

View File

@ -12,13 +12,9 @@ PKG_NAME:=nmap
PKG_VERSION:=4.20
PKG_RELEASE:=1
PKG_MD5SUM:=ea50419f99472200c4184a304e3831ea
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://download.insecure.org/nmap/dist
PKG_CAT:=bzcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
PKG_MD5SUM:=ea50419f99472200c4184a304e3831ea
include $(INCLUDE_DIR)/package.mk
@ -27,26 +23,26 @@ define Package/nmap
CATEGORY:=Network
DEPENDS:=+libdnet +libpcap +libpcre +uclibcxx
TITLE:=Network exploration and/or security auditing utility
DESCRIPTION:=\
A free open source utility for network exploration or security auditing.
URL:=http://www.insecure.org/nmap/
endef
define Build/Configure
$(call Build/Configure/Default, \
--without-openssl \
--without-nmapfe \
--with-libdnet="$(STAGING_DIR)/usr" \
--with-libpcap="$(STAGING_DIR)/usr" \
--with-libpcre="$(STAGING_DIR)/usr" \
, \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -luClibc++ -lc -lm -lgcc" \
)
define Package/nmap/description
A free open source utility for network exploration or security auditing.
endef
CONFIGURE_ARGS += \
--without-openssl \
--without-nmapfe \
--with-libdnet="$(STAGING_DIR)/usr" \
--with-libpcap="$(STAGING_DIR)/usr" \
--with-libpcre="$(STAGING_DIR)/usr" \
CONFIGURE_VARS += \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
LIBS="-nodefaultlibs -luClibc++" \
define Build/Compile
mkdir -p $(PKG_INSTALL_DIR)
$(MAKE) -C $(PKG_BUILD_DIR) \
DESTDIR="$(PKG_INSTALL_DIR)" \
all install

View File

@ -18,64 +18,73 @@ PKG_MD5SUM:=b400d03c0e39e3e78a7327ba78f789f0
include $(INCLUDE_DIR)/package.mk
define Package/rrs
define Package/rrs/Default
SECTION:=net
CATEGORY:=Network
DEPENDS:=+uclibcxx +libopenssl
TITLE:=A reverse (connecting) remote shell (with SSL support)
DEPENDS:=+uclibcxx
TITLE:=A reverse (connecting) remote shell
URL:=http://www.cycom.se/dl/rrs/
endef
define Package/rrs
$(call Package/rrs/Default)
SECTION:=net
CATEGORY:=Network
DEPENDS+= +libopenssl
TITLE+= (with SSL support)
URL:=http://www.cycom.se/dl/rrs/
endef
define Package/rrs-nossl
$(call Package/rrs/Default)
SECTION:=net
CATEGORY:=Network
DEPENDS:=+uclibcxx
TITLE:=A reverse (connecting) remote shell (without SSL support)
URL:=http://www.cycom.se/dl/rrs/
TITLE+= (without SSL support)
endef
ifneq ($(SDK),)
CONFIG_PACKAGE_rrs:=m
CONFIG_PACKAGE_rrs-nossl:=m
endif
define Build/Template
define Build/Compile/Template
$(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -fno-builtin -fno-rtti -nostdinc++" \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -Wl,-Bdynamic,-luClibc++,-Bstatic,-lstdc++,-Bdynamic $(3) -lutil -lm -lc" \
LDFLAGSNOSSL="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -Wl,-Bdynamic,-luClibc++,-Bstatic,-lstdc++,-Bdynamic $(3) -lutil -lm -lc" \
$(2)
( cd $(PKG_BUILD_DIR); mv rrs rrs-$(1); )
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs $(4) -luClibc++ -lm -lutil" \
LDFLAGSNOSSL="$(TARGET_LDFLAGS) -nodefaultlibs $(4) -luClibc++ -lm -lutil" \
$(3)
( cd $(PKG_BUILD_DIR); mv -f rrs rrs-$(2); )
touch $$@
$(STAMP_BUILT): $(STAMP_BUILT)-$(2)
define Package/$(1)/install
$(INSTALL_DIR) $$(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rrs-$(2) $$(1)/usr/bin/rrs
endef
ifneq ($(CONFIG_PACKAGE_rrs),)
define Build/Compile/with-ssl
$(call Build/Compile/Template,ssl,generic,-lcrypto -lssl)
endef
endif
endef
ifneq ($(CONFIG_PACKAGE_rrs-nossl),)
define Build/Compile/without-ssl
$(call Build/Compile/Template,nossl,generic-nossl,)
endef
endif
define Build/Configure
endef
define Build/Compile
$(call Build/Compile/with-ssl)
$(call Build/Compile/without-ssl)
endef
define Package/rrs/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rrs-ssl $(1)/usr/bin/rrs
endef
ifneq ($(SDK)$(CONFIG_PACKAGE_rrs),)
define Build/with-ssl
$(call Build/Template,rrs,with-ssl,generic,-lcrypto -lssl)
endef
endif
$(eval $(Build/with-ssl))
ifneq ($(SDK)$(CONFIG_PACKAGE_rrs-nossl),)
define Build/without-ssl
$(call Build/Template,rrs-nossl,without-ssl,generic-nossl,)
endef
endif
$(eval $(Build/without-ssl))
define Package/rrs-nossl/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rrs-nossl $(1)/usr/bin/rrs
endef
$(eval $(call BuildPackage,rrs))
$(eval $(call BuildPackage,rrs-nossl))

View File

@ -0,0 +1,12 @@
diff -ruN rrs-1.70-old/Makefile rrs-1.70-new/Makefile
--- rrs-1.70-old/Makefile 2004-05-30 02:14:14.000000000 +0200
+++ rrs-1.70-new/Makefile 2007-09-01 16:26:09.000000000 +0200
@@ -50,7 +50,7 @@
$(CC) $(CFLAGS) $(LDFLAGS) $(LDEXTRA) -o $(out) rrs.c md5.c sha1.c farm9crypt.cc twofish2.cc
compile-generic-nossl:
- $(CC) -DWITHOUT_SSL $(CFLAGS) $$CFLAGS $(LDFLAGSNOSSL) $(LDEXTRA) -o $(out) rrs.c md5.c sha1.c farm9crypt.cc twofish2.cc
+ $(CC) -DWITHOUT_SSL $(CFLAGS) $(LDFLAGSNOSSL) $(LDEXTRA) -o $(out) rrs.c md5.c sha1.c farm9crypt.cc twofish2.cc
## qnx
compile-qnx:

View File

@ -15,7 +15,6 @@ PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/sipp
PKG_MD5SUM:=8866e9af0d3bc29e91ebb6eab89a7f1f
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
@ -24,13 +23,16 @@ include $(INCLUDE_DIR)/package.mk
define Package/sipp
SECTION:=net
CATEGORY:=Network
DEPENDS:=+uclibcxx +libpthread +libncurses
DEPENDS:= +libncurses +libpthread +uclibcxx
TITLE:=test tool / traffic generator for the SIP protocol
DESCRIPTION:=\
SIPp is a free Open Source test tool / traffic generator for the SIP protocol.\\\
It includes a few basic SipStone user agent scenarios (UAC and UAS) and\\\
establishes and releases multiple calls with the INVITE and BYE methods.\\\
URL:=http://sipp.sourceforge.net
URL:=http://sipp.sourceforge.net/
endef
define Package/sipp/description
SIPp is a free Open Source test tool / traffic generator for the SIP
protocol. It includes a few basic SipStone user agent scenarios (UAC and
UAS) and establishes and releases multiple calls with the INVITE and BYE
methods.
endef
define Build/Compile
@ -40,15 +42,15 @@ define Build/Compile
CPP_linux="$(TARGET_CC)" \
CCLINK_linux="$(TARGET_CC)" \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS_linux="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -fno-builtin -nostdinc++" \
LFLAGS_linux="-nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
LIBS="-luClibc++ -lc -lm -lgcc -lpthread -ldl -lncurses" \
CPPFLAGS_linux="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
LFLAGS_linux="$(TARGET_LDFLAGS)" \
LIBS="-nodefaultlibs -lncurses -luClibc++ -ldl -lpthread" \
all
endef
define Package/sipp/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/sipp $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,sipp))

View File

@ -26,24 +26,26 @@ define Package/vncrepeater
CATEGORY:=Network
DEPENDS:=+uclibcxx
TITLE:=UltraVNC repeater for Linux
DESCRIPTION:=\
Viewer can be behind Nat router or directly connected to the internet \\\
Instead of forwarding serveral ports, you only need to forward 1 port \\\
If the PC that runs the Repeater has access to the local DNS server, \\\
you can use your local DNS names instead of 10.10.10.12.\\\
This could be handy when you have a dynamic DHCP server allocating \\\
ip adresses for your PC.
URL:=http://ultravnc.sourceforge.net/addons/repeater.html
endef
define Package/vncrepeater/
define Package/vncrepeater/conffiles
/etc/vncrepeater.conf
endef
define Package/vncrepeater/description
Viewer can be behind Nat router or directly connected to the internet
instead of forwarding serveral ports, you only need to forward 1 port.
If the PC that runs the Repeater has access to the local DNS server,
you can use your local DNS names instead of 10.10.10.12.
This could be handy when you have a dynamic DHCP server allocating
ip adresses for your PC.
endef
define Build/Compile
$(call Build/Compile/Default, \
CFLAGS="$(TARGET_CFLAGS) -fno-builtin -fno-rtti -nostdinc++" \
STAGING_DIR="$(STAGING_DIR)" \
CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -luClibc++" \
repeater \
)
endef

View File

@ -6,7 +6,7 @@ diff -urN vncrepeater-0.12/Makefile vncrepeater-0.12.new/Makefile
+CFLAGS=-Wall
repeater: repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
- g++ $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o
+ $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o -nodefaultlibs -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib -luClibc++
+ $(CC) $(CFLAGS) -o repeater repeater.o repeaterproc.o openbsd_stringfuncs.o iniparser.o readini.o $(LDFLAGS)
repeater.o: repeater.cpp
- g++ $(CFLAGS) -c repeater.cpp

View File

@ -12,13 +12,9 @@ PKG_NAME:=xmail
PKG_VERSION:=1.24
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.xmailserver.org/
PKG_MD5SUM:=106730bdbaa4fda9e90a7c22df024114
PKG_CAT:=zcat
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
@ -27,25 +23,27 @@ define Package/xmail
CATEGORY:=Network
DEPENDS:=+uclibcxx +libopenssl
TITLE:=advanced, fast and reliable ESMTP/POP3 mail server
DESCRIPTION:=\
XMail is an Internet mail server featuring an SMTP, POP3 and finger server. \\\
It's incredibly easy to set up and has lots of features including : \\\
multiple domains, virtual users and spam protection.
URL:=http://www.xmailserver.org/
endef
define Package/xmail/description
XMail is an Internet mail server featuring an SMTP, POP3 and finger server.
It's incredibly easy to set up and has lots of features including :
multiple domains, virtual users and spam protection.
endef
define Build/Configure
$(CP) ./files/SysMachine.h $(PKG_BUILD_DIR)/
endef
define Build/Compile
CFLAGS="$(TARGET_CFLAGS)" \
$(MAKE) -C $(PKG_BUILD_DIR) -f Makefile.lnx \
$(TARGET_CONFIGURE_OPTS) \
LDFLAGS="$(EXTRA_LDFLAGS) -luClibc++ -lssl -lm -lpthread -lcrypto -ldl" \
WITH_SSL_INCLUDE="$(STAGING_DIR)/usr/include" \
WITH_SSL_LIB="$(STAGING_DIR)/usr/lib" \
CPPFLAGS="$(TARGET_CFLAGS)" \
CXX="$(TARGET_CROSS)g++"
LD="\$$$$(CC)" \
CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/uClibc++ -fno-builtin -fno-rtti -nostdinc++" \
LDFLAGS="$(TARGET_LDFLAGS) -nodefaultlibs -lcrypto -lssl -luClibc++ -ldl -lm -lpthread" \
all
endef
define Package/xmail/install