utils/procps: fix "Unknown HZ value!" on some machines. (closes #8161)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23943 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
18ec98d374
commit
2b442b1fdc
33
utils/procps/patches/020_hz_fix.patch
Normal file
33
utils/procps/patches/020_hz_fix.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- a/proc/sysinfo.c
|
||||
+++ b/proc/sysinfo.c
|
||||
@@ -209,7 +209,7 @@ static int check_for_privs(void){
|
||||
return !!rc;
|
||||
}
|
||||
|
||||
-static void init_libproc(void) __attribute__((constructor));
|
||||
+static void init_libproc(void) __attribute__((constructor(200)));
|
||||
static void init_libproc(void){
|
||||
have_privs = check_for_privs();
|
||||
// ought to count CPUs in /proc/stat instead of relying
|
||||
--- a/proc/version.c
|
||||
+++ b/proc/version.c
|
||||
@@ -33,7 +33,7 @@ void display_version(void) {
|
||||
|
||||
int linux_version_code;
|
||||
|
||||
-static void init_Linux_version(void) __attribute__((constructor));
|
||||
+static void init_Linux_version(void) __attribute__((constructor(100)));
|
||||
static void init_Linux_version(void) {
|
||||
static struct utsname uts;
|
||||
int x = 0, y = 0, z = 0; /* cleared in case sscanf() < 3 */
|
||||
--- a/proc/module.mk
|
||||
+++ b/proc/module.mk
|
||||
@@ -76,7 +76,7 @@ proc/$(ANAME): $(LIBOBJ)
|
||||
|
||||
#proc/$(SONAME): proc/library.map
|
||||
proc/$(SONAME): $(LIBOBJ)
|
||||
- $(CC) $(ALL_CFLAGS) $(ALL_LDFLAGS) -shared -Wl,-soname,$(SONAME) -Wl,--version-script=proc/library.map -o $@ $^ -lc
|
||||
+ $(CC) $(ALL_CFLAGS) $(ALL_LDFLAGS) -shared -Wl,-soname,$(SONAME) -Wl,--version-script=proc/library.map -o $@ $(sort $^) -lc
|
||||
|
||||
|
||||
# AUTOMATIC DEPENDENCY GENERATION -- GCC AND GNUMAKE DEPENDENT
|
Loading…
x
Reference in New Issue
Block a user