port matrixssl to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4165 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1edcc102a3
commit
2bdc6020ae
62
libs/matrixssl/Makefile
Normal file
62
libs/matrixssl/Makefile
Normal file
@ -0,0 +1,62 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=matrixssl
|
||||
PKG_VERSION:=1.2.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://nbd.vd-s.ath.cx/openwrt
|
||||
PKG_MD5SUM:=771c1489488e62668d673478311d63ca
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libmatrixssl
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+libpthread
|
||||
TITLE:=Embedded SSL implementation
|
||||
DESCRIPTION:=An embedded SSL implementation.
|
||||
URL:=http://www.matrixssl.org/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)/src \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
DFLAGS="$(TARGET_CFLAGS) -Wall"
|
||||
endef
|
||||
|
||||
define Package/libmatrixssl/install
|
||||
install -d -m0755 $(1)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/src/libmatrixssl.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/include/matrixSsl
|
||||
$(CP) $(PKG_BUILD_DIR)/matrixSsl.h $(STAGING_DIR)/usr/include/matrixSsl
|
||||
ln -sf matrixSsl/matrixSsl.h $(STAGING_DIR)/usr/include/matrixSsl.h
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_BUILD_DIR)/src/libmatrixssl.so* $(STAGING_DIR)/usr/lib
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/include/matrixSsl* \
|
||||
$(STAGING_DIR)/usr/lib/libmatrixssl.so*
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libmatrixssl))
|
1971
libs/matrixssl/patches/matrixssl-1.2.4.diff
Normal file
1971
libs/matrixssl/patches/matrixssl-1.2.4.diff
Normal file
File diff suppressed because it is too large
Load Diff
12
libs/matrixssl/patches/matrixssl-typefix.patch
Normal file
12
libs/matrixssl/patches/matrixssl-typefix.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -urN matrixssl.old/src/os/linux/linux.c matrixssl/src/os/linux/linux.c
|
||||
--- matrixssl.old/src/os/linux/linux.c 2005-02-23 22:43:10.000000000 +0100
|
||||
+++ matrixssl/src/os/linux/linux.c 2005-03-06 01:52:51.000000000 +0100
|
||||
@@ -51,7 +51,7 @@
|
||||
static sslTime_t hiresStart; /* zero-time */
|
||||
static sslTime_t hiresFreq; /* tics per second */
|
||||
#else /* __i386__ */
|
||||
-static unsigned int32 prevTicks; /* Check wrap */
|
||||
+static uint32 prevTicks; /* Check wrap */
|
||||
static sslTime_t elapsedTime; /* Last elapsed time */
|
||||
#endif
|
||||
|
Loading…
x
Reference in New Issue
Block a user