lighttpd:
* Update: 1.4.15 > 1.4.16 * Cleanup Makefile * Refresh patches git-svn-id: svn://svn.openwrt.org/openwrt/packages@8170 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e3e2997fd5
commit
2cb749fa0b
@ -9,14 +9,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lighttpd
|
||||
PKG_VERSION:=1.4.15
|
||||
PKG_RELEASE:=1
|
||||
PKG_VERSION:=1.4.16
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.lighttpd.net/download/
|
||||
PKG_MD5SUM:=b994b8c359da578dec073cae52c4924f
|
||||
PKG_CAT:=bzcat
|
||||
PKG_MD5SUM:=ea671997591f772417b7e540d325f8cc
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
@ -141,38 +140,31 @@ define Package/lighttpd-mod-webdav
|
||||
endef
|
||||
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--libdir=/usr/lib/lighttpd \
|
||||
--sysconfdir=/etc/lighttpd \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--without-attr \
|
||||
--without-bzip2 \
|
||||
--without-fam \
|
||||
--without-gdbm \
|
||||
--without-ldap \
|
||||
--without-lua \
|
||||
--without-memcache \
|
||||
--without-mysql \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--with-pcre \
|
||||
--without-valgrind \
|
||||
--with-webdav-props \
|
||||
, \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS" \
|
||||
PCRE_LIB="-lpcre" \
|
||||
);
|
||||
endef
|
||||
CONFIGURE_ARGS += \
|
||||
--libdir=/usr/lib/lighttpd \
|
||||
--sysconfdir=/etc/lighttpd \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
--disable-rpath \
|
||||
--without-attr \
|
||||
--without-bzip2 \
|
||||
--without-fam \
|
||||
--without-gdbm \
|
||||
--without-ldap \
|
||||
--without-lua \
|
||||
--without-memcache \
|
||||
--without-mysql \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--with-pcre \
|
||||
--without-valgrind \
|
||||
--with-webdav-props \
|
||||
, \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include/libxml2 $$$$CPPFLAGS" \
|
||||
PCRE_LIB="-lpcre"
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
MAKE_FLAGS += \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
|
||||
define Package/lighttpd/install
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
|
@ -1,18 +1,20 @@
|
||||
diff -ubr /tmp/lighttpd-1.4.13/configure lighttpd-1.4.13/configure
|
||||
--- /tmp/lighttpd-1.4.13/configure 2006-10-09 16:39:03.000000000 -0500
|
||||
+++ lighttpd-1.4.13/configure 2007-03-03 19:45:44.000000000 -0600
|
||||
@@ -24587,7 +24587,7 @@
|
||||
echo "$as_me:$LINENO: result: $WITH_PCRE" >&5
|
||||
echo "${ECHO_T}$WITH_PCRE" >&6
|
||||
Index: lighttpd-1.4.16/configure
|
||||
===================================================================
|
||||
--- lighttpd-1.4.16.orig/configure 2007-07-26 11:58:37.000000000 +0200
|
||||
+++ lighttpd-1.4.16/configure 2007-07-26 11:58:37.000000000 +0200
|
||||
@@ -23844,7 +23844,7 @@
|
||||
{ echo "$as_me:$LINENO: result: $WITH_PCRE" >&5
|
||||
echo "${ECHO_T}$WITH_PCRE" >&6; }
|
||||
|
||||
-if test "x$cross_compiling" = xno -a "$WITH_PCRE" != "no"; then
|
||||
+if test "$WITH_PCRE" != "no"; then
|
||||
# Extract the first word of "pcre-config", so it can be a program name with args.
|
||||
set dummy pcre-config; ac_word=$2
|
||||
echo "$as_me:$LINENO: checking for $ac_word" >&5
|
||||
diff -ubr /tmp/lighttpd-1.4.13/configure.in lighttpd-1.4.13/configure.in
|
||||
--- /tmp/lighttpd-1.4.13/configure.in 2006-10-09 11:19:34.000000000 -0500
|
||||
+++ lighttpd-1.4.13/configure.in 2007-03-03 19:50:50.000000000 -0600
|
||||
{ echo "$as_me:$LINENO: checking for $ac_word" >&5
|
||||
Index: lighttpd-1.4.16/configure.in
|
||||
===================================================================
|
||||
--- lighttpd-1.4.16.orig/configure.in 2007-07-26 11:58:37.000000000 +0200
|
||||
+++ lighttpd-1.4.16/configure.in 2007-07-26 11:58:37.000000000 +0200
|
||||
@@ -250,7 +250,7 @@
|
||||
[WITH_PCRE=$withval],[WITH_PCRE=yes])
|
||||
AC_MSG_RESULT([$WITH_PCRE])
|
||||
|
Loading…
x
Reference in New Issue
Block a user