[packages] collectd: currently the build fails due to the combination of -Werror and deprecation warnings in libgcrypt used by mod-network - drop the usage of -Werror for now

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29489 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-12-09 18:02:03 +00:00
parent 5780dfdc12
commit 2ff38ce890
2 changed files with 23 additions and 1 deletions

View File

@ -0,0 +1,22 @@
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -7,7 +7,7 @@ SUBDIRS += liboconfig
endif
if COMPILER_IS_GCC
-AM_CFLAGS = -Wall -Werror
+AM_CFLAGS = -Wall
endif
AM_CPPFLAGS = -DPREFIX='"${prefix}"'
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -1836,7 +1836,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
SUBDIRS = libcollectdclient $(am__append_1) $(am__append_2)
-@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall -Werror
+@COMPILER_IS_GCC_TRUE@AM_CFLAGS = -Wall
AM_CPPFLAGS = -DPREFIX='"${prefix}"' \
-DCONFIGFILE='"${sysconfdir}/${PACKAGE_NAME}.conf"' \
-DLOCALSTATEDIR='"${localstatedir}"' \

View File

@ -231,7 +231,7 @@
+ continue;
+
+ if (strstr(ifname, "mon.") || strstr(ifname, ".sta") ||
+ strstr(ifname, "wmaster") || strstr(ifname, "wifi"))
+ strstr(ifname, "tmp.") || strstr(ifname, "wifi"))
+ continue;
+
+ iwinfo_process(ifname);