packages: update alsa-utils to 1.0.27.2
Signed-off-by: Peter Wagner <tripolar@gmx.at> Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@37690 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9a0677947b
commit
30ac8c0caa
@ -8,13 +8,13 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=alsa-utils
|
PKG_NAME:=alsa-utils
|
||||||
PKG_VERSION:=1.0.24.2
|
PKG_VERSION:=1.0.27.2
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
|
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
|
||||||
http://alsa.cybermirror.org/utils/
|
http://alsa.cybermirror.org/utils/
|
||||||
PKG_MD5SUM:=8238cd57cb301d1c36bcf0ecb59ce6b2
|
PKG_MD5SUM:=b65e9a04181bd7c9db7667a4566f8dc3
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
@ -1,8 +1,6 @@
|
|||||||
Index: alsa-utils-1.0.24.2/alsamixer/volume_mapping.c
|
--- a/alsamixer/volume_mapping.c
|
||||||
===================================================================
|
+++ b/alsamixer/volume_mapping.c
|
||||||
--- alsa-utils-1.0.24.2.orig/alsamixer/volume_mapping.c 2011-03-11 13:26:29.000000000 +0100
|
@@ -114,9 +114,9 @@ static double get_normalized_volume(snd_
|
||||||
+++ alsa-utils-1.0.24.2/alsamixer/volume_mapping.c 2011-03-11 13:27:58.000000000 +0100
|
|
||||||
@@ -109,9 +109,9 @@
|
|
||||||
if (use_linear_dB_scale(min, max))
|
if (use_linear_dB_scale(min, max))
|
||||||
return (value - min) / (double)(max - min);
|
return (value - min) / (double)(max - min);
|
||||||
|
|
||||||
@ -14,7 +12,7 @@ Index: alsa-utils-1.0.24.2/alsamixer/volume_mapping.c
|
|||||||
normalized = (normalized - min_norm) / (1 - min_norm);
|
normalized = (normalized - min_norm) / (1 - min_norm);
|
||||||
}
|
}
|
||||||
|
|
||||||
@@ -144,7 +144,7 @@
|
@@ -149,7 +149,7 @@ static int set_normalized_volume(snd_mix
|
||||||
}
|
}
|
||||||
|
|
||||||
if (min != SND_CTL_TLV_DB_GAIN_MUTE) {
|
if (min != SND_CTL_TLV_DB_GAIN_MUTE) {
|
||||||
|
Loading…
x
Reference in New Issue
Block a user