packages: update alsa-lib to 1.0.27.2

Signed-off-by: Peter Wagner <tripolar@gmx.at>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@37689 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jogo 2013-08-04 16:41:35 +00:00
parent 436bdd9268
commit 9a0677947b
4 changed files with 25 additions and 66 deletions

View File

@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=alsa-lib
PKG_VERSION:=1.0.24.1
PKG_VERSION:=1.0.27.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/lib/ \
http://alsa.cybermirror.org/lib/
PKG_MD5SUM:=7cc05f25e1d5b65da8fb3fdcd540f226
PKG_MD5SUM:=69129a7c37697f81ac092335e9fa452b
PKG_LICENSE:=LGPLv2.1 GPLv2
PKG_LICENSE_FILE:=COPYING aserver/COPYING
@ -41,7 +41,6 @@ TARGET_CFLAGS += $(FPIC)
define Build/Configure
$(call Build/Configure/Default, \
--enable-static \
--disable-python \
--disable-debug \
--without-debug \
@ -58,7 +57,7 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libasound.{la,a,so*} \
$(PKG_INSTALL_DIR)/usr/lib/libasound.{la,so*} \
$(1)/usr/lib/
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/alsa.pc \

View File

@ -1,24 +1,24 @@
Index: alsa-lib-1.0.24.1/src/Makefile.in
===================================================================
--- alsa-lib-1.0.24.1.orig/src/Makefile.in
+++ alsa-lib-1.0.24.1/src/Makefile.in
@@ -372,7 +372,7 @@ clean-libLTLIBRARIES:
rm -f "$${dir}/so_locations"; \
done
libasound.la: $(libasound_la_OBJECTS) $(libasound_la_DEPENDENCIES)
diff --git a/src/Makefile.in b/src/Makefile.in
index e21fc0d..c8f3ea0 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -419,7 +419,7 @@ clean-libLTLIBRARIES:
rm -f $${locs}; \
}
libasound.la: $(libasound_la_OBJECTS) $(libasound_la_DEPENDENCIES) $(EXTRA_libasound_la_DEPENDENCIES)
- $(AM_V_CCLD)$(libasound_la_LINK) -rpath $(libdir) $(libasound_la_OBJECTS) $(libasound_la_LIBADD) $(LIBS)
+ $(AM_V_CCLD)$(libasound_la_LINK) -rpath $(DESTDIR)$(libdir) $(libasound_la_OBJECTS) $(libasound_la_LIBADD) $(LIBS)
mostlyclean-compile:
-rm -f *.$(OBJEXT)
Index: alsa-lib-1.0.24.1/src/pcm/scopes/Makefile.in
===================================================================
--- alsa-lib-1.0.24.1.orig/src/pcm/scopes/Makefile.in
+++ alsa-lib-1.0.24.1/src/pcm/scopes/Makefile.in
@@ -300,7 +300,7 @@ clean-pkglibLTLIBRARIES:
rm -f "$${dir}/so_locations"; \
done
scope-level.la: $(scope_level_la_OBJECTS) $(scope_level_la_DEPENDENCIES)
diff --git a/src/pcm/scopes/Makefile.in b/src/pcm/scopes/Makefile.in
index 469dbb5..391f3d4 100644
--- a/src/pcm/scopes/Makefile.in
+++ b/src/pcm/scopes/Makefile.in
@@ -348,7 +348,7 @@ clean-pkglibLTLIBRARIES:
rm -f $${locs}; \
}
scope-level.la: $(scope_level_la_OBJECTS) $(scope_level_la_DEPENDENCIES) $(EXTRA_scope_level_la_DEPENDENCIES)
- $(AM_V_CCLD)$(scope_level_la_LINK) -rpath $(pkglibdir) $(scope_level_la_OBJECTS) $(scope_level_la_LIBADD) $(LIBS)
+ $(AM_V_CCLD)$(scope_level_la_LINK) -rpath $(DESTDIR)$(pkglibdir) $(scope_level_la_OBJECTS) $(scope_level_la_LIBADD) $(LIBS)

View File

@ -1,8 +1,8 @@
Index: alsa-lib-1.0.24.1/configure.in
===================================================================
--- alsa-lib-1.0.24.1.orig/configure.in 2011-01-31 15:18:50.000000000 +0100
+++ alsa-lib-1.0.24.1/configure.in 2012-06-09 15:57:42.600834238 +0200
@@ -22,22 +22,6 @@
diff --git a/configure.in b/configure.in
index 00fff2b..af39300 100644
--- a/configure.in
+++ b/configure.in
@@ -24,22 +24,6 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AC_PREFIX_DEFAULT(/usr)
@ -15,7 +15,7 @@ Index: alsa-lib-1.0.24.1/configure.in
-
- which ${program_prefix}gcc >/dev/null 2>&1 && CC=${program_prefix}gcc
- which ${host_cpu}-${host_os}-gcc >/dev/null 2>&1 \
- && CC=${host_cpu}-${host-os}-gcc
- && CC=${host_cpu}-${host_os}-gcc
- which ${host_cpu}-${host_vendor}-${host_os}-gcc >/dev/null 2>&1 \
- && CC=${host_cpu}-${host_vendor}-${host_os}-gcc
-

View File

@ -1,40 +0,0 @@
diff --git a/include/iatomic.h b/include/iatomic.h
index e92dbfd..364bc5c 100644
--- a/include/iatomic.h
+++ b/include/iatomic.h
@@ -720,7 +720,7 @@ typedef struct { volatile int counter; } atomic_t;
* Atomically adds @i to @v. Note that the guaranteed useful range
* of an atomic_t is only 24 bits.
*/
-extern __inline__ void atomic_add(int i, atomic_t * v)
+static __inline__ void atomic_add(int i, atomic_t * v)
{
unsigned long temp;
@@ -744,7 +744,7 @@ extern __inline__ void atomic_add(int i, atomic_t * v)
* Atomically subtracts @i from @v. Note that the guaranteed
* useful range of an atomic_t is only 24 bits.
*/
-extern __inline__ void atomic_sub(int i, atomic_t * v)
+static __inline__ void atomic_sub(int i, atomic_t * v)
{
unsigned long temp;
@@ -763,7 +763,7 @@ extern __inline__ void atomic_sub(int i, atomic_t * v)
/*
* Same as above, but return the result value
*/
-extern __inline__ int atomic_add_return(int i, atomic_t * v)
+static __inline__ int atomic_add_return(int i, atomic_t * v)
{
unsigned long temp, result;
@@ -784,7 +784,7 @@ extern __inline__ int atomic_add_return(int i, atomic_t * v)
return result;
}
-extern __inline__ int atomic_sub_return(int i, atomic_t * v)
+static __inline__ int atomic_sub_return(int i, atomic_t * v)
{
unsigned long temp, result;