Add the URBI package

git-svn-id: svn://svn.openwrt.org/openwrt/packages@9110 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2007-10-03 09:30:11 +00:00
parent 7a9740e8de
commit 316c24a297
2 changed files with 98 additions and 0 deletions

67
lang/urbi/Makefile Normal file
View File

@ -0,0 +1,67 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id: $
include $(TOPDIR)/rules.mk
PKG_NAME:=urbi
PKG_VERSION:=1.0RC2-l455
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-sdk-$(PKG_VERSION)-src.zip
PKG_SOURCE_URL:=http://www.gostai.com/downloads/aibo/
PKG_MD5SUM:=02f64abb6232ddd7b0cb6dc182e2df26
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-sdk
include $(INCLUDE_DIR)/package.mk
define Package/urbi
SECTION:=lang
CATEGORY:=Languages
DEPENDS:=+uclibcxx +libpthread
TITLE:=URBI SDK
URL:=http://www.urbiforge.com
endef
define Package/urbi/description
Universal Real-Time Behavior Interface for robots.
endef
CONFIGURE_VARS += \
CXX="g++-uc" \
CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
EXAMPLES=0 \
define Build/Compile
$(call Build/Compile/Default,\
DESTDIR="$(PKG_INSTALL_DIR)" \
all install \
)
endef
define Build/InstallDev
$(INSTALL_DIR) $(STAGING_DIR)/usr/include/urbi
$(CP) $(PKG_INSTALL_DIR)/usr/include/urbi* $(STAGING_DIR)/usr/include/urbi/
$(INSTALL_DIR) $(STAGING_DIR)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liburbi* $(STAGING_DIR)/usr/lib/
endef
define Build/UninstallDev
rm -rf $(STAGING_DIR)/usr/include/urbi
endef
define Package/urbi/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/gostai
$(CP) $(PKG_INSTALL_DIR)/usr/gostai/* $(1)/usr/gostai/
endef
$(eval $(call BuildPackage,urbi))

View File

@ -0,0 +1,31 @@
diff -urN urbi-sdk/src/Makefile.am urbi-sdk.new/src/Makefile.am
--- urbi-sdk/src/Makefile.am 2007-01-31 11:37:04.000000000 +0100
+++ urbi-sdk.new/src/Makefile.am 2007-10-03 11:17:00.000000000 +0200
@@ -1,5 +1,5 @@
SUBDIRS = liburbi
if EXAMPLES
-SUBDIRS += utils examples
+SUBDIRS += utils
endif
diff -urN urbi-sdk/src/Makefile.in urbi-sdk.new/src/Makefile.in
--- urbi-sdk/src/Makefile.in 2007-04-10 17:44:07.000000000 +0200
+++ urbi-sdk.new/src/Makefile.in 2007-10-03 11:14:33.000000000 +0200
@@ -30,7 +30,7 @@
POST_UNINSTALL = :
build_triplet = @build@
host_triplet = @host@
-@EXAMPLES_TRUE@am__append_1 = utils examples
+@EXAMPLES_TRUE@am__append_1 = utils
subdir = src
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in
ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
@@ -68,7 +68,7 @@
distclean-recursive maintainer-clean-recursive
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = liburbi utils examples
+DIST_SUBDIRS = liburbi utils
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
INSTALL_HEADER = @INSTALL_HEADER@
ACLOCAL = @ACLOCAL@