batman: cleanup and honor copts, updated to 0.2-rv478 as well
git-svn-id: svn://svn.openwrt.org/openwrt/packages@8281 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
db71886c26
commit
3192f096c0
@ -8,15 +8,15 @@
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=batman-III
|
||||
PKG_VERSION:=0.2.0a
|
||||
PKG_NAME:=batmand
|
||||
PKG_VERSION:=0.2-rv478
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tbz2
|
||||
PKG_SOURCE_URL:=http://downloads.open-mesh.net/batman
|
||||
PKG_MD5SUM:=d5ac8329633590ed072a6b7ecccacf0b
|
||||
PKG_CAT:=bzcat
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)_$(PKG_VERSION)_sources
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_sources.tgz
|
||||
PKG_SOURCE_URL:=http://downloads.open-mesh.net/batman/stable/sources/
|
||||
PKG_MD5SUM:=b00ad9603e32c85224d5b19f99126ddf
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
@ -33,18 +33,15 @@ endef
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C "$(PKG_BUILD_DIR)" \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
NODEBUG=1 \
|
||||
OFLAGS="$(TARGET_CFLAGS)" \
|
||||
UNAME="Linux" \
|
||||
INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
|
||||
STRIP="/bin/true" \
|
||||
batmand install
|
||||
endef
|
||||
MAKE_FLAGS += \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CCFLAGS="$(TARGET_CFLAGS)" \
|
||||
OFLAGS="$(TARGET_CFLAGS)" \
|
||||
NODEBUG=1 \
|
||||
UNAME="Linux" \
|
||||
INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
|
||||
STRIP="/bin/true" \
|
||||
batmand install
|
||||
|
||||
define Package/batman/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
|
@ -1,18 +1,20 @@
|
||||
--- batman-III-0.2.0a.old/Makefile 2007-02-28 15:41:11.000000000 +0100
|
||||
+++ batman-III-0.2.0a/Makefile 2007-02-28 15:42:02.000000000 +0100
|
||||
@@ -27,6 +27,7 @@
|
||||
CFLAGS = -Wall -O0 -g3
|
||||
LDFLAGS = -lpthread
|
||||
#LDFLAGS = -static -lpthread
|
||||
+SBINDIR = $(INSTALL_PREFIX)/usr/sbin
|
||||
Index: batmand_0.2-rv478_sources/Makefile
|
||||
===================================================================
|
||||
--- batmand_0.2-rv478_sources.orig/Makefile 2007-07-31 14:26:18.000000000 -0500
|
||||
+++ batmand_0.2-rv478_sources/Makefile 2007-07-31 14:28:43.000000000 -0500
|
||||
@@ -21,6 +21,7 @@
|
||||
CFLAGS = -Wall -O1 -g3 -DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA
|
||||
STRIP= strip
|
||||
LDFLAGS = -lpthread -static
|
||||
+SBINDIR = $(INSTALL_PREFIX)/usr/sbin
|
||||
|
||||
UNAME=$(shell uname)
|
||||
CFLAGS_MIPS = -Wall -O1 -g3
|
||||
LDFLAGS_MIPS = -lpthread
|
||||
@@ -264,3 +265,7 @@
|
||||
|
||||
@@ -67,3 +68,7 @@
|
||||
|
||||
clean:
|
||||
rm -f batmand batmand-mips* *.o *~
|
||||
clean-long:
|
||||
rm -rf batmand_*
|
||||
+
|
||||
+install:
|
||||
+ mkdir -p $(SBINDIR)
|
||||
+ install -m 755 batmand $(SBINDIR)
|
||||
+ install -m 0755 batmand $(SBINDIR)
|
||||
|
Loading…
x
Reference in New Issue
Block a user